Bug 599141 - SELinux is preventing /usr/sbin/lxdm-binary "write" access on /var/run/lxdm/lxdm.auth.
SELinux is preventing /usr/sbin/lxdm-binary "write" access on /var/run/l...
Status: CLOSED DUPLICATE of bug 599151
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:cc29fbb513e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 14:20 EDT by Jesús Franco
Modified: 2010-12-04 15:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 14:46:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesús Franco 2010-06-02 14:20:01 EDT
Resúmen:

SELinux is preventing /usr/sbin/lxdm-binary "write" access on
/var/run/lxdm/lxdm.auth.

Descripción Detallada:

SELinux denied access requested by lxdm-binary. It is not expected that this
access is required by lxdm-binary and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Permitiendo Acceso:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Información Adicional:

Contexto Fuente               system_u:system_r:xdm_t:s0-s0:c0.c1023
Contexto Destino              system_u:object_r:var_run_t:s0
Objetos Destino               /var/run/lxdm/lxdm.auth [ file ]
Fuente                        lxdm-binary
Dirección de Fuente          /usr/sbin/lxdm-binary
Puerto                        <Desconocido>
Nombre de Equipo              (eliminado)
Paquetes RPM Fuentes          lxdm-0.2.0-4.fc13
Paquetes RPM Destinos         
RPM de Políticas             selinux-policy-3.7.19-21.fc13
SELinux Activado              True
Tipo de Política             targeted
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (eliminado)
Plataforma                    Linux (eliminado) 2.6.33.3-85.fc13.i686 #1 SMP Thu May
                              6 18:44:12 UTC 2010 i686 i686
Cantidad de Alertas           1
Visto por Primera Vez         mié 02 jun 2010 05:32:20 CDT
Visto por Última Vez         mié 02 jun 2010 05:32:20 CDT
ID Local                      f3039747-06bd-4cb6-be7e-abe1a2cd19b6
Números de Línea            

Mensajes de Auditoría Crudos 

node=(eliminado) type=AVC msg=audit(1275474740.658:55): avc:  denied  { write } for  pid=1340 comm="lxdm-binary" name="lxdm.auth" dev=sda1 ino=297 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file

node=(eliminado) type=SYSCALL msg=audit(1275474740.658:55): arch=40000003 syscall=5 success=no exit=-13 a0=996b760 a1=241 a2=1b6 a3=804ee59 items=0 ppid=1 pid=1340 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="lxdm-binary" exe="/usr/sbin/lxdm-binary" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,lxdm-binary,xdm_t,var_run_t,file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t var_run_t:file write;
Comment 1 Daniel Walsh 2010-06-02 14:46:22 EDT

*** This bug has been marked as a duplicate of bug 599151 ***

Note You need to log in before you can comment on or make changes to this bug.