Bug 59917 - Crash on network config (gtk2 bug)
Summary: Crash on network config (gtk2 bug)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-14 20:29 UTC by andrewem
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 20:21:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description andrewem 2002-02-14 20:29:32 UTC
From Bugzilla Helper:

Description of problem:
The network configuration page for setting-up eth0 seems to have major 
problems, causing the installer to crash.

Version-Release number of selected component (if applicable):
Hampton (beta 1) 7.2.90

How reproducible:
Sometimes

Steps to Reproduce:
I've not found a 100% method, but have crashed the installer (with some null 
trap message) multiple ways, such as un-checking the dhcp box then hitting 
forward button then the back button.  I suspect there is some sort of data 
validation that needs to be looked at carfully.

Actual Results:
Installer crashes and halts systems with a polite message.

Expected Results:
Installer to continue to next step.

Additional info:
None.

Comment 1 Michael Fulbright 2002-02-15 18:56:51 UTC
Matt is this a gtk issue?

Comment 2 Matt Wilson 2002-02-16 16:20:15 UTC
this is a gtk bug in the incremental reflow timer of the tree view.

Comment 3 Jay Turner 2002-03-20 14:11:23 UTC
Assumming you are not seeing this in Beta 2?

Comment 4 Matt Wilson 2002-03-20 15:18:46 UTC
deferred for next gtk2 anaconda

Comment 5 Michael Fulbright 2002-05-09 19:40:38 UTC
I could not reproduce this issue, but there are other issues on this screen.

For example, you can enter invalid characters into the entry fields for IP.

Will fix using some code from jrb.

Comment 6 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.