Bug 599175 - conflicting tracepoint power.h headers
Summary: conflicting tracepoint power.h headers
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Mark Wielaard
QA Contact: Han Pingtian
URL:
Whiteboard:
Keywords:
: 610503 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 19:30 UTC by Josh Stone
Modified: 2010-11-11 16:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 16:14:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Josh Stone 2010-06-02 19:30:11 UTC
Kernel v2.6.32 shipped with both "include/trace/power.h" and "include/trace/events/power.h".  The former is superseded by the latter, introduced in commit 6161352.  Commit 192dcf1 cleans this up, but unfortunately not until 2.6.33.

This is tripping up SystemTap, which uses automatic scans to find tracepoints under include/trace/.  We end up trying to use both power.h's, which mask each other by the duplicate _TRACE_POWER_H.


$ stap -e 'probe kernel.trace("power*") { next }' -p4
/tmp/stapP05llp/stap_5c867073e806d7cfabb464b245ec1569_834.c: In function ‘register_tracepoint_probe_3’:
/tmp/stapP05llp/stap_5c867073e806d7cfabb464b245ec1569_834.c:695: error: implicit declaration of function ‘register_trace_power_frequency’
/tmp/stapP05llp/stap_5c867073e806d7cfabb464b245ec1569_834.c: In function ‘unregister_tracepoint_probe_3’:
/tmp/stapP05llp/stap_5c867073e806d7cfabb464b245ec1569_834.c:698: error: implicit declaration of function ‘unregister_trace_power_frequency’
make[1]: *** [/tmp/stapP05llp/stap_5c867073e806d7cfabb464b245ec1569_834.o] Error 1
make: *** [_module_/tmp/stapP05llp] Error 2
Pass 4: compilation failed.  Try again with another '--vp 0001' option.


Please pull commit 192dcf1 to RHEL6 too.

Comment 2 RHEL Product and Program Management 2010-06-07 16:05:07 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Frank Ch. Eigler 2010-06-21 16:36:37 UTC
posted to rhkernel-list by mjw

Comment 5 Aristeu Rozanski 2010-07-01 16:25:16 UTC
Patch(es) available on kernel-2.6.32-42.el6

Comment 7 Mark Wielaard 2010-07-02 09:45:31 UTC
*** Bug 610503 has been marked as a duplicate of this bug. ***

Comment 9 Han Pingtian 2010-08-13 21:48:03 UTC
Verified with 2.6.32-54.el6.

Comment 10 releng-rhel@redhat.com 2010-11-11 16:14:00 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.