Bug 599203 - ReviewBoard looks for sqlite3, but in RHEL/EPEL it's known as sqlite
Summary: ReviewBoard looks for sqlite3, but in RHEL/EPEL it's known as sqlite
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ReviewBoard   
(Show other bugs)
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 20:28 UTC by Ray Van Dolson
Modified: 2010-06-02 21:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 20:47:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ray Van Dolson 2010-06-02 20:28:13 UTC
Description of problem:
Attempting to set up ReviewBoard with sqlite.  I have sqlite and python-sqlite packages installed, but ReviewBoard doesn't see them.  It appears (per cmdline/rbsite.py) that ReviewBoard checks for a sqlite3 module which doesn't exist in RHEL/EPEL.

Instead ReviewBoard should check for sqlite.

Version-Release number of selected component (if applicable):
ReviewBoard-1.0.5.1-2.1.el5

How reproducible:
Always

Steps to Reproduce:
1. Install ReviewBoard, sqlite and python-sqlite packages on EL5.
2. Run rb-install
  
Actual results:
sqlite3 is listed as missing.

Expected results:
sqlite should be a DB option.

Additional info:
Perhaps there's a way to alias this module as a workaround.

Comment 1 Stephen Gallagher 2010-06-02 20:47:25 UTC
On RHEL5, you need to install the python-sqlite2 package. ReviewBoard will detect this and use that interface instead of the sqlite3 interface. This is because the version of sqlite3 that ReviewBoard needs is newer than that which is available for RHEL5, but it also has a compatible sqlite2 interface.

Comment 2 Ray Van Dolson 2010-06-02 21:04:21 UTC
Thanks Stephen, sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.