Bug 59922 - Sound badly distorted on nForce chipset (ASUS A7N266-E MOBO)
Sound badly distorted on nForce chipset (ASUS A7N266-E MOBO)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-14 18:52 EST by Greg Corson
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 16:19:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Corson 2002-02-14 18:52:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Just updated my mobo to an nForce based one (ASUS A7N266-e).  Kudzu detected the
on board sound as i810 (wrong?) Sound comes out but is badly distorted.  When
sound is quiet, you hear quiet squeals in the background.  When playing sound it
is tinny and distorted with a background hiss that seems to go up and down in
volume along with the sound being played.  NO clicking or skips though...sounds
as if it might not be using all the bits of the codec or badly resampling the
data.  kernel messages are:

Feb 12 19:47:36 alien kernel: Intel 810 + AC97 Audio, version 0.19, 13:48:53 Jan
17 2002
Feb 12 19:47:36 alien kernel: PCI: Enabling device 00:06.0 (0005 -> 0007)
Feb 12 19:47:36 alien kernel: PCI: Setting latency timer of device 00:06.0 to 64
Feb 12 19:47:36 alien kernel: i810: NVIDIA nForce Audio found at IO 0xe000 and
0xe100, IRQ 5
Feb 12 19:47:37 alien kernel: i810_audio: Audio Controller supports 6 channels.
Feb 12 19:47:37 alien kernel: ac97_codec: AC97 Audio codec, id: 0x8384:0x7609
(SigmaTel STAC9721/23)
Feb 12 19:47:37 alien kernel: i810_audio: only 48Khz playback available.
Feb 12 19:47:37 alien kernel: i810_audio: AC'97 codec 0 supports AMAP, total
channels = 2
Feb 12 19:47:37 alien kernel: ac97_codec: AC97 Audio codec, id: 0x8384:0x7608
(SigmaTel STAC9708)
Feb 12 19:47:38 alien modprobe: modprobe: Can't locate module sound-service-0-0
Feb 12 19:47:38 alien modprobe: modprobe: Can't locate module sound-slot-1
Feb 12 19:47:38 alien modprobe: modprobe: Can't locate module sound-service-1-0
Feb 12 19:47:38 alien modprobe: modprobe: Can't locate module sound-slot-1
Feb 12 19:47:38 alien modprobe: modprobe: Can't locate module sound-service-1-0
Feb 12 19:47:44 alien kernel: i810_audio: timed out waiting for codec 1 analog
readyhdc: ATAPI 56X CD-ROM drive, 128kB Cache

I'm told the chip can be used as an AC97 codec with i810 drivers but also has
other more advanced features.

I'm running the latest Athlon kernel from RHN 2.4.9-21

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.1. install RH7.2, custom, everything checked
2. update to latest kernel via RHN
3. Sound quality is bad (tinny with background white noise) may not be obvious
if you just give it a quick listen or have bad speakers.  Sound doesn't skip,
just doesn't sound good.
 
2.
3.
	

Actual Results:  Sound quality poor

Expected Results:  Sound quality should be very good, windows users report
exceptionally good quality sound when playing back MP3 or game music so I assume
the problem is linux driver related.

Additional info:

This board/chipset is looking to be very popular as performs very well and is
cheap for what you get.  It should really be supported.
Comment 1 Elliot Lee 2002-05-06 12:29:34 EDT
Depending on how you are playing the sound (which you did not describe), this
might actually be an esound issue. Try grabbing the esound from RHL 7.3 and
seeing if the fixes in that help.
Comment 2 Eric Hattemer 2002-07-04 09:35:47 EDT
NVIDIA has drivers on their site somewhere www.nvidia.com for the nforce and 
linux.  These drivers contain the nforce sound driver, which is a hacked i810 
driver.  Try those drivers if you haven't already.
Comment 3 Arjan van de Ven 2003-06-07 16:19:24 EDT
current errata kernels have support for this hw

Note You need to log in before you can comment on or make changes to this bug.