Bug 599257 - RHEL6.0-20100529.n.0 nightly tree kvm installations hang on probing EDD
Summary: RHEL6.0-20100529.n.0 nightly tree kvm installations hang on probing EDD
Status: CLOSED DUPLICATE of bug 596881
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: beta
: ---
Assignee: Gleb Natapov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 23:52 UTC by Gurhan Ozen
Modified: 2013-12-09 00:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 14:41:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gurhan Ozen 2010-06-02 23:52:07 UTC
Description of problem:
This was brought to my attention when kvm guests with the latest stable rhel6 tree (RHEL6.0-20100529.n.0 nightly) has failed in beaker. It seems like the installation hangs after loading initrd.img with the message "Probing EDD (edd=off to disable)" .

Providing edd=off to the kernel line works and the installation moves on. 

Just install the guest with the following command:

/usr/sbin/virt-install --name i386_plain_iso --cdrom /var/lib/libvirt/images/rhel6_i386_plain.iso --ram=1024 --vcpus=1 --file-size=10 --hvm --debug --prompt --accelerate --os-variant=virtio26 --network bridge:br0 --noreboot --vnc --file /var/lib/libvirt/images/i386_plain_iso.img 


Version-Release number of selected component (if applicable):
RHEL6.0-20100529.n.0 nightly tree. 
# rpm -qa | egrep "^kernel|^kvm|^qemu"
kernel-firmware-2.6.32-32.el6.noarch
kernel-2.6.32-31.el6.x86_64
kernel-devel-2.6.32-32.el6.x86_64
qemu-img-0.12.1.2-2.68.el6.x86_64
qemu-kvm-0.12.1.2-2.68.el6.x86_64
kernel-headers-2.6.32-32.el6.x86_64
kernel-2.6.32-32.el6.x86_64
kernel-devel-2.6.32-31.el6.x86_64

How reproducible:
Everytime.

Steps to Reproduce:
1./usr/sbin/virt-install --name i386_plain_iso --cdrom /var/lib/libvirt/images/rhel6_i386_plain.iso --ram=1024 --vcpus=1 --file-size=10 --hvm --debug --prompt --accelerate --os-variant=virtio26 --network bridge:br0 --noreboot --vnc --file /var/lib/libvirt/images/i386_plain_iso.img 

2.
3.
  
Actual results:
Hangs when it boots off of boot.iso

Expected results:


Additional info:
providing edd=off in the kernel line works.

Comment 1 Dor Laor 2010-06-03 13:52:41 UTC
Why is that a bug? Probably the virt bios does not support EDD.

Comment 2 Amit Shah 2010-06-03 14:41:55 UTC

*** This bug has been marked as a duplicate of bug 596881 ***


Note You need to log in before you can comment on or make changes to this bug.