Bug 59930 - gdm dies right after putting up login screen
gdm dies right after putting up login screen
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gdm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-14 21:54 EST by Jonathan Kamens
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-15 00:03:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-02-14 21:54:04 EST
I just upgraded a whole bunch of packages from Raw Hide (the current versions as
of the morning of February 14):

	* Upgraded: GConf2 ORBit2 VFlib2 VFlib2-devel XFree86-100dpi-fonts
	XFree86 XFree86-75dpi-fonts XFree86-Xvfb XFree86-base-fonts
	XFree86-devel XFree86-doc XFree86-font-utils XFree86-libs
	XFree86-tools XFree86-truetype-fonts XFree86-twm XFree86-xf86cfg
	XFree86-xfs arts atk authconfig binutils bonobo-activation cups
	cups-devel cups-libs cyrus-sasl cyrus-sasl-devel cyrus-sasl-md5
	findutils gdm glib2 glib2-devel gnome-vfs gnome-vfs2 gtk2 imap
	intltool kernel-utils libIDL libart_lgpl libbonobo libbonoboui
	libglade2 libgnome libgnomecanvas libgnomeui librsvg2 libtool
	libtool-libs libuser libxml2 libxslt linc modutils ncurses
	ncurses-devel openldap openldap-devel pam_krb5 pango parted popt
	samba samba-client samba-common sane-backends sane-backends-devel
	sh-utils splint tetex-afm tetex-doc tetex-dvilj tetex-dvips
	tetex-fonts tetex-xdvi ttfonts xsri.

I upgraded my kernel to 2.4.18-pre9-ac3 at the same time, but I doubt that's
relevant.

After rebooting, gdm starts up, starts an X server, and puts up the login
window, and then the X server immediately dies.  This happens several times, and
then gdm gives up and disables the X server.  I can't find the reason why the X
server is dying right after it starts up logged *anywhere*.  I've looked in
/var/log/messages and /var/log/gdm; there is no useful information in either of
them.  Any suggestions for how to debug this?

If I log in on the console and run "xinit", it works just fine.
Comment 1 Jonathan Kamens 2002-02-14 22:29:05 EST
It appears that gdmgreeter is crashing.  I enabled debugging in gdm.conf and saw
this:

Feb 14 22:21:05 jik gdm[3407]: Sending GREETPID == 3415 for slave 3407
Feb 14 22:21:05 jik gdm[3407]: Sending GREETPID 3407 3415
Feb 14 22:21:05 jik gdm[3365]: Handling message: 'GREETPID 3407 3415'
Feb 14 22:21:05 jik gdm[3365]: Got GREETPID == 3415
Feb 14 22:21:05 jik gdm[3407]: gdm_slave_usr2_handler: :0 got USR2 signal
Feb 14 22:21:10 jik gdm[3407]: gdm_slave_wait_for_login: In loop
Feb 14 22:21:10 jik gdm[3407]: gdm_slave_child_handler
Feb 14 22:21:10 jik gdm[3407]: gdm_slave_child_handler: 3415 died
Feb 14 22:21:10 jik gdm[3407]: gdm_slave_child_handler: 3415 died of 11

Then I made this change to /etc/X11/gdm/gdm.conf, and now I can log in with gdm:

--- gdm.conf	2002/02/15 03:25:15	1.1
+++ gdm.conf	2002/02/15 03:26:03	1.2
@@ -9,9 +9,9 @@
 Chooser=/usr/bin/gdmchooser --disable-sound --disable-crash-dialog
 DefaultPath=/bin:/usr/bin:/usr/bin/X11:/usr/local/bin:/usr/bin
 DisplayInitDir=/etc/X11/gdm/Init
-Greeter=/usr/bin/gdmgreeter
+#Greeter=/usr/bin/gdmgreeter
 #Uncomment this for the regular greeter
-#Greeter=/usr/bin/gdmlogin --disable-sound --disable-crash-dialog
+Greeter=/usr/bin/gdmlogin --disable-sound --disable-crash-dialog
 Group=gdm
 HaltCommand=/usr/bin/poweroff
 KillInitClients=true

If you can't duplicate this, let me know and I'll try to collect more
information about why gdmgreeter is crashing.
Comment 2 Havoc Pennington 2002-02-14 22:33:28 EST
GTK ABI was broken, but the various other libs gdm uses weren't rebuilt - that
could cause this crash.
Comment 3 Alexander Larsson 2002-02-15 00:03:05 EST
Yeah. If you back down your glib and gtk+ RPMs it works. This will be fixed
soon. We just need to recompile everything...
Comment 4 Bill Nottingham 2002-03-28 17:24:15 EST
Please reopen if this persists...

Note You need to log in before you can comment on or make changes to this bug.