Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 599334 - Screen resolution only 800x600, no option to change better than that, while fedora 13 has better
Screen resolution only 800x600, no option to change better than that, while f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Desktop, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 03:16 EDT by A S Alam
Modified: 2013-07-02 21:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.7.7-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:58:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Virtual machine with low resolution on screen (125.72 KB, image/png)
2010-06-03 03:16 EDT, A S Alam
no flags Details
xorg file /var/log/Xorg.0.log (16.10 KB, text/plain)
2010-06-03 05:12 EDT, A S Alam
no flags Details
it is fixed - Screenshot with both applications (256.14 KB, image/png)
2010-06-09 06:43 EDT, A S Alam
no flags Details

  None (edit)
Description A S Alam 2010-06-03 03:16:45 EDT
Created attachment 419262 [details]
Virtual machine with low resolution on screen

Description of problem:
after installing Virtual machine, resolution of VM's screen always 800x600, which 
is not good for various application (testing gnome-display-properties, RHN registration) as Buttons are not available
Video = cirrus, RAM 9MB
Host Machine: Fedora 13 x86_64
Guest: RHEL6 Nightly (1June2010)

Version-Release number of selected component (if applicable):
xorg-x11-drv-cirrus-1.3.2-1.1.el6.x86_64
xorg-x11-server-common-1.7.7-3.el6.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
xorg-x11-drv-vesa-2.2.1-2.el6.x86_64
xorg-x11-drivers-7.3-13.2.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. install virtual machine with cirrus video (default in fedora virt-manager)
2.  reboot after installation
3. login desktop, run 'gnome-display-properties'
  
Actual results:
it is 800x600

Expected results:
can be better

Additional info:
install fedora 13 as guest, it has better resolution with same host machine with  same 'cirrus' video card.
Comment 2 A S Alam 2010-06-03 05:12:18 EDT
Created attachment 419289 [details]
xorg file /var/log/Xorg.0.log
Comment 3 A S Alam 2010-06-03 23:24:57 EDT
Even vesa is not better, but same resolution:-(
xorg-x11-drv-vesa-2.3.0-1.el6
Comment 4 RHEL Product and Program Management 2010-06-07 12:14:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Adam Jackson 2010-06-07 14:37:19 EDT
That definitely shouldn't be.  It looks like this is fallout from the DMT mode list update in the X server core though, cirrus is definitely carrying the patch for qemu detection.  Hm hm hm.

Devel ack at any rate.
Comment 6 Adam Jackson 2010-06-07 14:51:32 EDT
Yeah, this is a server bug.  Patch ready.
Comment 10 Adam Jackson 2010-06-08 13:03:51 EDT
2502555 build (RHEL-6-candidate, /cvs/dist:rpms/xorg-x11-server/RHEL-6:xorg-x11-server-1_7_7-5_el6) completed successfully

MODIFIED
Comment 11 A S Alam 2010-06-09 06:43:00 EDT
Created attachment 422503 [details]
it is fixed - Screenshot with both applications
Comment 12 A S Alam 2010-06-09 06:45:57 EDT
tested application:
xorg-x11-server-Xorg-1.7.7-5.el6.x86_64.rpm
Comment 13 Lubos Kocman 2010-06-18 08:12:04 EDT
Verified

I'm able to get 1024x768 (RHEL6.x86_64 cirrus/kvm).

xorg-x11-drv-cirrus-1.3.2-1.1.el6
xorg-x11-server-Xorg-1.7.7-11.el6
Comment 14 releng-rhel@redhat.com 2010-11-10 16:58:36 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.