Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 599463 - The network driver in ifcfg-eth0 fails to be converted (kvm-rhel5u4-64bit)
The network driver in ifcfg-eth0 fails to be converted (kvm-rhel5u4-64bit)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 05:59 EDT by Rita Wu
Modified: 2013-07-02 21:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-18 23:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot about some info in the guest (134.84 KB, image/png)
2010-06-03 05:59 EDT, Rita Wu
no flags Details
log during conversion from LIBGUESTFS_TRACE=1 (73 bytes, text/plain)
2010-06-03 06:47 EDT, Rita Wu
no flags Details
log from virt-inspect before conversion (691.67 KB, text/plain)
2010-06-03 06:49 EDT, Rita Wu
no flags Details

  None (edit)
Description Rita Wu 2010-06-03 05:59:27 EDT
Created attachment 419303 [details]
Screen Shot about some info in the guest

Description of problem:
kvm-rhel5u4-64bit guest cannot get IP, due to the /etc/sysconfig/network-script/ifcft-eth0 is using 8139 driver.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-3.el5

How reproducible:
always

Steps to Reproduce:
1.virt-v2v -f /etc/virt-v2v.conf -o rhev -osd 10.66.70.80:/v2v/fcp_export cleankvm-RHEL-5.5-64.raw
virt-v2v: cleankvm-RHEL-5.5-64.raw configured with virtio drivers
virt-v2v: Failed to unmount 10.66.70.80:/v2v/fcp_export. Command exited with status 1. Output was: umount: /tmp/AwacXSdVfg: device is busy
umount: /tmp/AwacXSdVfg: device is busy

virt-v2v: Failed to remove mount directory /tmp/AwacXSdVfg: Device or resource busy


2. Import the VM to "Virtual Machine" tab 
3. Run the guest
#lsmod |grep -i virtio
#/etc/init.d/network start
#
  
Actual results:
The vm can show in the rhevm UI, but after importing the VM cannot get the IP

Expected results:
The VM can get the IP.

Additional info:
Comment 2 Rita Wu 2010-06-03 06:47:30 EDT
Created attachment 419327 [details]
log during conversion from LIBGUESTFS_TRACE=1
Comment 3 Rita Wu 2010-06-03 06:49:51 EDT
Created attachment 419328 [details]
log from virt-inspect before conversion

Update the steps(sorry,pasted the wrong output before):

#LIBGUEST_TRACE=1 virt-v2v -f /etc/virt-v2v.conf -o rhev -osd 10.66.70.80:/v2v/fcp_export cleankvm-RHEL-Server-5.4-64.raw 2>&1 > cleankvm-RHEL-Server-5.4-64-conversion.log
#
Comment 4 Matthew Booth 2010-06-03 08:34:06 EDT
Linglu,

Could you have another go at the LIBGUESTFS_TRACE output? It looks like this contains just the regular output.

Also, could you please post the contents of /etc/modprobe.conf both before and after conversion?

Thanks,

MAtt
Comment 5 Rita Wu 2010-06-04 00:58:04 EDT
Before conversion:

# cat /etc/modprobe.conf
alias eth0 8139cp
[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

After conversion:
# cat /etc/modprobe.conf
alias eth0 virt_net
[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
Comment 6 Rita Wu 2010-06-04 05:26:02 EDT
Hi Matt,

It seems this bug cannot reproduce every time. Anyway, I'll reserve those converted guests for you if you need. One more thing to pay attention is the uncomment info in ifcfg-eh0 is still 8139:
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+

It should be 
#Virtio Network Device
Comment 8 Rita Wu 2010-06-05 05:02:58 EDT
I cannot reproduce it now and devel, too. Since it's RC period, so remove blocker flag. But we'll still track on this bug later, so set it as ON_QA.
Comment 9 Matthew Booth 2010-06-07 04:56:46 EDT
This bug appears to relate to a comment not being updated. This is certainly not the cause of any underlying lack of network connectivity.

I strongly suspect that the issue was either temporary and local (i.e. temporarily unable to get DHCP response for any number of reasons), or a typo in conversion meaning the guest was trying to attach to a non-existent RHEV network.
Comment 10 Rita Wu 2010-06-07 06:02:23 EDT
(In reply to comment #9)
> This bug appears to relate to a comment not being updated. This is certainly
> not the cause of any underlying lack of network connectivity.
> 
> I strongly suspect that the issue was either temporary and local (i.e.
> temporarily unable to get DHCP response for any number of reasons), or a typo
> in conversion meaning the guest was trying to attach to a non-existent RHEV
> network.    

The strange things is that the VM cannot get IP will always fails to get IP, and the VM can get IP will always succeed to get IP, although all configuration and images are the same.

At the same time, I'm sure the network interface is "RHEVM" when the VM is running.

Anyway,I'll try to reproduce it.
Comment 11 Matthew Booth 2010-07-16 12:29:59 EDT
I'd like to close this bug, as I believe the issue was temporary and not related to virt-v2v. Any objections?
Comment 12 Rita Wu 2010-07-18 23:08:47 EDT
Yeah, I cannot reproduce it with the latest virt-v2v 6.1-1.el5.

Note You need to log in before you can comment on or make changes to this bug.