Bug 599500 - Evolution data server fails
Summary: Evolution data server fails
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-03 11:34 UTC by Arthur Buliva
Modified: 2010-11-15 15:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 07:56:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 620733 None None None Never

Description Arthur Buliva 2010-06-03 11:34:38 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. Install and run evolution from terminal
2. Add a task
3. Click the GNOME Clock applet in order to load tasks
4. Data server crashes, making the tasks unable to be viewed
  
Actual results:

"Your tasks will not be displayed until evolution is started"

Expected results:

Expected that tasks are shown

Additional info:

Comment 1 Matthew Barnes 2010-06-06 10:51:28 UTC
Moving this upstream for better visibility.
Please see [1] for further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=620733

Comment 2 Arthur Buliva 2010-06-06 17:02:20 UTC
Stack trace 1:

sh-4.1$ evolution
(evolution:2542): e-data-server-DEBUG: Loading categories from "/home/arthur/.evolution/categories.xml"
(evolution:2542): e-data-server-DEBUG: Loaded 29 categories
RSS Plugin enabled (evolution 2.30, evolution-rss 0.1.9)
Rspam Plugin enabled (evolution 2.30, evolution-rspam 0.0.99)

** (evolution:2542): CRITICAL **: taskbar_push_message: assertion `rss_shell_view != NULL' failed
No servers available!  Maybe try the 'discover' command
child process output:  len: 1

** (evolution:2542): CRITICAL **: taskbar_pop_message: assertion `rss_shell_view != NULL' failed
Reading RSS articles...

(evolution:2542): libecal-WARNING **: e-cal.c:404: e-d-s proxy died
notification.c(362) taskbar_op_finish():activity_key:0x8e9b718
feed BBC News | News Front Page | World Edition
RSS: cleaning all remaining sessions ...done
sh-4.1$

---------------------------------------------

Stacktrace 2:

sh-4.1$ evolution
(evolution:9099): e-data-server-DEBUG: Loading categories from "/home/wolfgang/.evolution/categories.xml"
(evolution:9099): e-data-server-DEBUG: Loaded 29 categories

(evolution:9099): GLib-GObject-WARNING **: value "-3.000000" of type `gdouble' is invalid or out of range for property `width' of type `gdouble'

(evolution:9099): GLib-GObject-WARNING **: value "-3.000000" of type `gdouble' is invalid or out of range for property `width' of type `gdouble'

(evolution:9099): GLib-GObject-WARNING **: value "-3.000000" of type `gdouble' is invalid or out of range for property `width' of type `gdouble'

(evolution:9099): GLib-GObject-WARNING **: value "-3.000000" of type `gdouble' is invalid or out of range for property `width' of type `gdouble'

(evolution:9099): GLib-GObject-WARNING **: value "-3.000000" of type `gdouble' is invalid or out of range for property `width' of type `gdouble'

(evolution:9099): GLib-GObject-WARNING **: value "-3.000000" of type `gdouble' is invalid or out of range for property `width' of type `gdouble'
e_cal_view_start: Message did not receive a reply (timeout by message bus)

(evolution:9099): libecal-WARNING **: e-cal-view.c:425: Unable to start view

(evolution:9099): libecal-WARNING **: e-cal.c:404: e-d-s proxy died

(evolution:9099): calendar-gui-WARNING **: gnome-cal.c:1120: Could not create the query: The name :1.221 was not provided by any .service files

(evolution:9099): calendar-gui-WARNING **: gnome-cal.c:1120: Could not create the query: The name :1.221 was not provided by any .service files

(evolution:9099): calendar-gui-WARNING **: e-cal-model.c:2125: Unable to get query, The name :1.221 was not provided by any .service files

(evolution:9099): libecal-WARNING **: e-cal.c:404: e-d-s proxy died

(evolution:9099): libecal-WARNING **: e-cal.c:404: e-d-s proxy died

(evolution:9099): libecal-WARNING **: e-cal.c:404: e-d-s proxy died

(evolution:9099): libecal-WARNING **: e-cal.c:404: e-d-s proxy died

(evolution:9099): libecal-CRITICAL **: file e-cal.c: line 3949: assertion `priv->proxy' failed

(evolution:9099): libecal-CRITICAL **: file e-cal.c: line 1147: assertion `priv->proxy' failed

(evolution:9099): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
sh-4.1$

Comment 3 Milan Crha 2010-06-07 07:56:02 UTC
Hi Arthur, could we move to the upstream bug report, please? And for a real backtrace, could you try this:
a) close evolution
b) pkill -QUIT e-calendar-factory
c) gdb /usr/libexec/e-calendar-factory --ex r --ex "t a a bt"

And add result of the c) command (since you run it to the end when it stops and prints the stack trace) to the upstream bug report, please? Also, make sure you've installed debug info packages for evolution, evolution-data-server and any other evolution-related packages you use (I see evolution-rss for example). Thanks in advance. (In case you do not have an upstream bugzilla account then feel free to paste results here, though still the upstream bug report would be the best.)


Note You need to log in before you can comment on or make changes to this bug.