Bug 59955 - [hampton] scroll bars in installer don't drag with "emulate 3 buttons" checked
[hampton] scroll bars in installer don't drag with "emulate 3 buttons" checked
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 66450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-15 16:52 EST by Don Smith
Modified: 2007-04-18 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-25 02:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Smith 2002-02-15 16:52:49 EST
Description of Problem:

If "Emulate 3 buttons" is checked in the mouse selection screen, the scrollbars 
on the rest of the screens cannot be dragged with the mouse, and holding down 
the button on the scroll arrows does not continuously scroll the frame.

Version-Release number of selected component (if applicable):


How Reproducible:
always

Steps to Reproduce:
1. Check the "emulate 3 buttons" option on the mouse selection screen
2. Continue to a screen with a scrollbar on it (timezone for example)
3. Attempt to drag the scrollbar

Actual Results:
Scrollbar does not drag with the mouse; the frame only scrolls by one page when 
the button is released.

Expected Results:
scrolling

Additional Information:
Comment 1 Michael Fulbright 2002-02-18 14:10:22 EST
I believe Matt speculated this was an X server issue?
Comment 2 Don Smith 2002-03-08 09:44:29 EST
Gone in beta 2 installer.
Comment 3 Jay Turner 2002-03-21 10:56:53 EST
Closing out.
Comment 4 Matt Wilson 2002-03-21 11:03:12 EST
need to verify in future gtk2 installer
Comment 5 Jeremy Katz 2002-06-11 11:43:24 EDT
*** Bug 66450 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-06-11 11:45:36 EDT
Still happens with current Milan trees... any ideas from the GTK+ experts?
Comment 7 Owen Taylor 2002-06-11 12:44:58 EDT
It basically has to be the X server giving bogus events.
Comment 8 Michael Fulbright 2002-06-13 14:33:11 EDT
Any idea how to address further owen?
Comment 9 Owen Taylor 2002-06-13 14:44:56 EDT
Run xev under the same conditions, look at what events you get?
Comment 10 Jeremy Katz 2002-07-25 02:14:29 EDT
Worked around by not enabling three button emulation for during the install;
it's not like we use the middle button there anyway
Comment 11 Mike McLean 2002-07-31 12:37:25 EDT
work-around confirmed.
Comment 12 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.