Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 59965 - Shell script problem in unknown update RPM for RH7.2 i386
Shell script problem in unknown update RPM for RH7.2 i386
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-16 01:35 EST by Need Real Name
Modified: 2015-01-07 18:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-18 09:22:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-16 01:35:55 EST
Description of Problem:

	This will be a shell script problem in an update RPM
	for an i386 RH 7.2 system but as I haven't identified
	the package, this will be filed against up2date.
	A large collection of packages were selected using
	up2date and during the installation phase, the
	following messages appeared:


warning: /etc/httpd/conf/httpd.conf created as /etc/httpd/conf/httpd.conf.rpmnew
warning: /etc/sysconfig/rhn/up2date created as /etc/sysconfig/rhn/up2date.rpmnew
/var/tmp/rpm-tmp.60659: [: /var/tmp/rpm-tmp.60659: integer expression expected


	The last one looks like a classic shell scripting
	problem.  This appeared towards the end of the
	procedure but I can't definitively pin it to a particular
	RPM.  All I can offer is the relevant log entries
	from /var/log/up2date:

[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date logging into up2date server
[Sat Feb 16 00:25:27 2002] up2date successfully retrived authentication token
from up2date server
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date getAvailablePackageList from network
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date solving dep for: ['Omni', 'Omni-foomatic']
[Sat Feb 16 00:25:27 2002] up2date installing packages: ['Mesa-3.4.2-10',
'Mesa-devel-3.4.2-10', 'XFree86-4.1.0-15', 'XFree86-100dpi-fonts-4.1.0-15',
'XFree86-75dpi-fonts-4.1.0-15', 'XFree86-ISO8859-2-100dpi-fonts-4.1.0-15',
'XFree86-ISO8859-2-75dpi-fonts-4.1.0-15',
'XFree86-ISO8859-9-100dpi-fonts-4.1.0-15',
'XFree86-ISO8859-9-75dpi-fonts-4.1.0-15', 'XFree86-Xnest-4.1.0-15',
'XFree86-Xvfb-4.1.0-15', 'XFree86-cyrillic-fonts-4.1.0-15',
'XFree86-devel-4.1.0-15', 'XFree86-libs-4.1.0-15', 'XFree86-tools-4.1.0-15',
'XFree86-twm-4.1.0-15', 'XFree86-xdm-4.1.0-15', 'XFree86-xf86cfg-4.1.0-15',
'XFree86-xfs-4.1.0-15', 'Xconfigurator-4.9.39-2', 'apache-1.3.22-2',
'apache-manual-1.3.22-2', 'arts-2.2.2-2', 'at-3.1.8-23', 'cyrus-sasl-1.5.24-23',
'cyrus-sasl-devel-1.5.24-23', 'cyrus-sasl-md5-1.5.24-23',
'cyrus-sasl-plain-1.5.24-23', 'eel-1.0.2-2', 'enscript-1.6.1-16.2',
'foomatic-1.1-0.20011218.3', 'gdb-5.1-1', 'ghostscript-6.51-16',
'glibc-2.2.4-19.3', 'glibc-common-2.2.4-19.3', 'glibc-devel-2.2.4-19.3',
'glibc-profile-2.2.4-19.3', 'groff-1.17.2-7.0.2',
'groff-gxditview-1.17.2-7.0.2', 'groff-perl-1.17.2-7.0.2', 'initscripts-6.43-1',
'iptables-1.2.4-2', 'jadetex-3.11-4', 'kde-i18n-French-2.2.2-2',
'kde-i18n-German-2.2.2-2', 'kde-i18n-Hebrew-2.2.2-2',
'kde-i18n-Japanese-2.2.2-2', 'kde-i18n-Russian-2.2.2-2', 'kdebase-2.2.2-1',
'kdelibs-2.2.2-2', 'kdelibs-devel-2.2.2-2', 'kdelibs-sound-2.2.2-2',
'kdenetwork-2.2.2-1', 'kdevelop-2.0.2-2', 'kernel-2.4.9-21',
'kernel-doc-2.4.9-21', 'kernel-headers-2.4.9-21', 'kernel-smp-2.4.9-21',
'kernel-source-2.4.9-21', 'libxml2-2.4.10-0.7x.2', 'libxslt-1.0.7-2',
'mod_ssl-2.8.5-1', 'modutils-2.4.13-0.7.1', 'mutt-1.2.5.1-1',
'nfs-utils-0.3.1-13.7.2.1', 'openldap-2.0.21-1', 'openldap-clients-2.0.21-1',
'openldap-devel-2.0.21-1', 'openldap-servers-2.0.21-1', 'openssh-2.9p2-12',
'openssh-askpass-2.9p2-12', 'openssh-askpass-gnome-2.9p2-12',
'openssh-clients-2.9p2-12', 'openssh-server-2.9p2-12', 'pam-0.75-19',
'pam-devel-0.75-19', 'pine-4.44-1.72.0', 'printconf-0.3.61-3',
'printconf-gui-0.3.61-3', 'python-xmlrpc-1.5.1-7.x.3', 'raidtools-0.90-24',
'redhat-config-network-0.9.10-2', 'rhn_register-2.7.2-7.x.8',
'rhn_register-gnome-2.7.2-7.x.8', 'rsync-2.4.6-10', 'sane-backends-1.0.5-4.1',
'stunnel-3.22-1', 'tetex-1.0.7-38.2', 'tetex-afm-1.0.7-38.2',
'tetex-dvilj-1.0.7-38.2', 'tetex-dvips-1.0.7-38.2', 'tetex-fonts-1.0.7-38.2',
'tetex-latex-1.0.7-38.2', 'tetex-xdvi-1.0.7-38.2', 'tmpwatch-2.8.1-1',
'ttfonts-ja-1.0-7', 'ucd-snmp-4.2.3-1.7.2.3', 'ucd-snmp-utils-4.2.3-1.7.2.3',
'up2date-2.7.11-7.x.2', 'up2date-gnome-2.7.11-7.x.2', 'usermode-1.46-1',
'util-linux-2.11f-17', 'vim-common-6.0-7.13', 'vim-minimal-6.0-7.13',
'wu-ftpd-2.6.1-20', 'xchat-1.8.7-1.72.0', 'xsane-0.82-3.1', 'Omni-0.5.0-4',
'Omni-foomatic-0.5.0-4']
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 1
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date Removing packages from package profile:
['Mesa-3.4.2-7', 'Mesa-devel-3.4.2-7', 'XFree86-4.1.0-3',
'XFree86-100dpi-fonts-4.1.0-3', 'XFree86-75dpi-fonts-4.1.0-3',
'XFree86-ISO8859-2-100dpi-fonts-4.1.0-3',
'XFree86-ISO8859-2-75dpi-fonts-4.1.0-3',
'XFree86-ISO8859-9-100dpi-fonts-4.1.0-3',
'XFree86-ISO8859-9-75dpi-fonts-4.1.0-3', 'XFree86-Xnest-4.1.0-3',
'XFree86-Xvfb-4.1.0-3', 'XFree86-cyrillic-fonts-4.1.0-3',
'XFree86-devel-4.1.0-3', 'XFree86-libs-4.1.0-3', 'XFree86-tools-4.1.0-3',
'XFree86-twm-4.1.0-3', 'XFree86-xdm-4.1.0-3', 'XFree86-xf86cfg-4.1.0-3',
'XFree86-xfs-4.1.0-3', 'Xconfigurator-4.9.39-1', 'apache-1.3.20-16',
'apache-manual-1.3.20-16', 'arts-2.2-11', 'at-3.1.8-20', 'cyrus-sasl-1.5.24-20',
'cyrus-sasl-devel-1.5.24-20', 'cyrus-sasl-md5-1.5.24-20',
'cyrus-sasl-plain-1.5.24-20', 'eel-1.0.1-19', 'enscript-1.6.1-14',
'foomatic-1.1-0.20010905.1', 'gdb-5.0rh-15', 'ghostscript-6.51-12',
'glibc-2.2.4-13', 'glibc-common-2.2.4-13', 'glibc-devel-2.2.4-13',
'glibc-profile-2.2.4-13', 'groff-1.17.2-3', 'groff-gxditview-1.17.2-3',
'groff-perl-1.17.2-3', 'initscripts-6.40-1', 'iptables-1.2.3-1',
'jadetex-3.6-4', 'kde-i18n-French-2.2-8', 'kde-i18n-German-2.2-8',
'kde-i18n-Hebrew-2.2-8', 'kde-i18n-Japanese-2.2-8', 'kde-i18n-Russian-2.2-8',
'kdebase-2.2-12', 'kdelibs-2.2-11', 'kdelibs-devel-2.2-11',
'kdelibs-sound-2.2-11', 'kdenetwork-2.2-7', 'kdevelop-2.0-1',
'kernel-doc-2.4.7-10', 'kernel-headers-2.4.7-10', 'kernel-source-2.4.7-10',
'libxml2-2.4.2-1', 'libxslt-1.0.1-3', 'mod_ssl-2.8.4-9', 'modutils-2.4.6-4',
'mutt-1.2.5i-17', 'nfs-utils-0.3.1-13', 'openldap-2.0.11-13',
'openldap-clients-2.0.11-13', 'openldap-devel-2.0.11-13',
'openldap-servers-2.0.11-13', 'openssh-2.9p2-7', 'openssh-askpass-2.9p2-7',
'openssh-askpass-gnome-2.9p2-7', 'openssh-clients-2.9p2-7',
'openssh-server-2.9p2-7', 'pam-0.75-14', 'pam-devel-0.75-14', 'pine-4.33-15',
'printconf-0.3.44-1', 'printconf-gui-0.3.44-1', 'python-xmlrpc-1.5.0-1',
'raidtools-0.90-23', 'redhat-config-network-0.9-1', 'rhn_register-2.7.2-7.x.2',
'rhn_register-gnome-2.7.2-7.x.2', 'rsync-2.4.6-5', 'sane-backends-1.0.5-4',
'stunnel-3.19-1', 'tetex-1.0.7-30', 'tetex-afm-1.0.7-30',
'tetex-dvilj-1.0.7-30', 'tetex-dvips-1.0.7-30', 'tetex-fonts-1.0.7-30',
'tetex-latex-1.0.7-30', 'tetex-xdvi-1.0.7-30', 'tmpwatch-2.8-2',
'ttfonts-ja-1.0-6', 'ucd-snmp-4.2.1-7', 'ucd-snmp-utils-4.2.1-7',
'up2date-2.7.2-7.x.6', 'up2date-gnome-2.7.2-7.x.6', 'usermode-1.43-1',
'util-linux-2.11f-9', 'vim-common-5.8-7', 'vim-minimal-5.8-7',
'wu-ftpd-2.6.1-18', 'xchat-1.8.1-2', 'xsane-0.77-4']
[Sat Feb 16 00:25:27 2002] up2date Modifying bootloader config to include the
new kernel info
[Sat Feb 16 00:25:27 2002] up2date Adding 2.4.9-21 to bootloader config
[Sat Feb 16 00:25:27 2002] up2date Adding 2.4.9-21smp to bootloader config
[Sat Feb 16 00:25:27 2002] up2date Installing the kernel via grub
[Sat Feb 16 00:25:27 2002] up2date Running /sbin/grubby --default-kernel
[Sat Feb 16 00:25:27 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Feb 16 00:25:27 2002] up2date deleting
/mnt/development/up2date/Mesa-3.4.2-10.i386.hdr


Version-Release number of selected component (if applicable):

	This up2date session was over a 7.0->7.2 upgrade install
	for intel.  There were numerous disk space issues on the
	way up which were resolved.

How Reproducible:

	I haven't attempted to reproduce and only have on system
	running RH so I can't help here.


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Michael Schwendt 2002-02-18 09:21:56 EST
That was bug #55091 in the previous iptables-1.2.3-1 package and was fixed with
the update you're referring to.
Comment 2 Bill Nottingham 2002-02-18 23:36:42 EST
It's a bug in the previous version of iptables, fixed in the errata version.

Note You need to log in before you can comment on or make changes to this bug.