Bug 59991 - [hampton] video test on Trio3D crashes installer
[hampton] video test on Trio3D crashes installer
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-18 09:40 EST by Don Smith
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Smith 2002-02-18 09:40:23 EST
Description of Problem:
[hampton]

On two different machines with Trio3D video, clicking the "test settings" 
button on the X configuration screen causes the installer to crash with a 
traceback and then drop out to text mode and shut down.

Version-Release number of selected component (if applicable):


How Reproducible:
always

Steps to Reproduce:
1. Click the "test settings" button on the X configuration screen

Actual Results:
A traceback window pops up, followed by the installer dropping to text mode and 
halting the system.

Expected Results:
Video test screen appears

Additional Information:
Using the "test settings" feature on other video chipsets didn't seem to cause 
any problems.
Comment 1 Michael Fulbright 2002-02-18 14:12:50 EST
Is any of the traceback left on the text screen? If so please include that
information.

Brock do we have any Trio3D cards? I don't think they've been in production for
a long time.
Comment 2 Don Smith 2002-02-19 14:00:59 EST
The following was left on the console screen --

Traceback (most recent call last):
  File "/usr/lib/anaconda/iw/config_gui.py", line 67, in testPressed
    self.xconfig.test (root="/mnt/sysimage")
  File "/usr/lib/anaconda/xf86config.py", line 1014, in test
OSError: [Errno 2] No such file or directory


Gtk-WARNING **: cannot open display: :9

anaconda (pid :79):  Gtk-ERROR **: The program 'anaconda' received an X Window 
System error. This probably reflects a bug in the program.
The error was 'BadIDChoice'.
  (Details: serial 584884 error_code 14 request_code 53 minor_code 0)
  (Note to programmers ... [stuff about X errors]
aborting...
install exited abnormally
Comment 3 Michael Fulbright 2002-02-19 14:40:20 EST
Could you give us the PCI ids of this card?

Do you know where we can get one, as we don't have any of these cards here.
Comment 4 Don Smith 2002-02-19 15:31:04 EST
Vendor ID: 0x5333
Device ID: 0x8904
(obtained via pcitweak)

Yes, it is sort of an old chipset - it's the on-board video on a couple of the 
older servers I am testing on. I saw a Trio3D card on eBay for $5... either 
there or maybe some parts store might have some old stuff laying around.
Comment 5 Michael Fulbright 2002-02-21 15:39:42 EST
Jay you think y'all could round up one of these?
Comment 6 Jay Turner 2002-02-22 11:33:17 EST
Can certainly try . . . wonder if we have one in one of the old test machines in
the lab?
Comment 7 Michael Fulbright 2002-02-25 15:52:06 EST
We do not seem to have this hardware in house - is it possible you could send us
one of these cards so we can diagnose the issue further?
Comment 8 Don Smith 2002-02-28 09:31:05 EST
I will check around to see if I can find one.
Comment 9 Wendy Hung 2002-03-01 09:40:03 EST
Chris Kloiber (ckloiber@redhat.com) has an IBM xSeries 240 which uses the S3 
Trio3D chipset in his hardware certification inventory.  Please contact him to 
obtain access to this hardware at Red Hat.
Comment 10 Michael Fulbright 2002-03-04 18:09:26 EST
Thanks we have located a machine now, will investigate.

This bug is against Hampton Beta 1 correct?
Comment 11 Don Smith 2002-03-05 08:36:46 EST
Yes, Hampton beta 1.
Comment 12 Jay Turner 2002-03-20 09:28:04 EST
Are we still seeing this in Beta 2?
Comment 13 Don Smith 2002-03-20 13:47:00 EST
I was unable to check on it in beta 2 because anaconda chokes on systems with 
Trio3D cards and I could not find a way around it to get the installer going - 
see bug #60898.
Comment 14 Don Smith 2002-03-25 09:43:32 EST
Not seeing this problem in beta 3, although the test screen that displays has 
the "strange mirroring effect" I described in bug #59956.
Comment 15 Bill Nottingham 2002-03-26 12:27:43 EST
This is probably fixed with going back to XFree3 for beta2/beta3.
Comment 16 Bill Nottingham 2002-03-26 12:28:07 EST
(this == failing to test video, not the driver artifacts)
Comment 17 Michael Fulbright 2002-03-26 12:32:14 EST
Deferring to future release.
Comment 18 Red Hat Bugzilla 2006-02-21 13:48:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.