Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 600068 - corosync logsys thread interrupted by signal results in segfault
corosync logsys thread interrupted by signal results in segfault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Steven Dake
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 18:03 EDT by Steven Dake
Modified: 2016-04-26 10:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: corosync-1.2.3-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 08:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
revision 2920 to fix problem (579 bytes, patch)
2010-06-03 20:34 EDT, Steven Dake
no flags Details | Diff

  None (edit)
Description Steven Dake 2010-06-03 18:03:28 EDT
Description of problem:
sem_wait error in thread is not checked.  It is possible for sem_wait to be interrupted by a signal, which will return -1 (errno=EINTR).  This causes the logsys thread to process information and leads to segfault.

Version-Release number of selected component (if applicable):
corosync-1.2.3-1

How reproducible:
can't reproduce - reported in field - field tested patch and verified it solves problem.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Steven Dake 2010-06-03 20:34:36 EDT
Created attachment 421078 [details]
revision 2920 to fix problem
Comment 3 RHEL Product and Program Management 2010-06-03 20:43:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 releng-rhel@redhat.com 2010-11-15 08:53:40 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.