Bug 60014 - cp -f and --remove-destination options do not work
cp -f and --remove-destination options do not work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-18 21:00 EST by Kevin Moore
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 08:15:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Moore 2002-02-18 21:00:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
when using the -f "force" option or the --remove-destination with the
cp command, I am still prompted to confirm overwriting files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cp any directory or file with the -f or --remove-destination option
2.
3.
	

Actual Results:  I was still prompted to confirm overwriting any existing files

Expected Results:  I expected files to be overwritten without requiring 
confirmation

Additional info:

I want to be able to crontab several daily file copies without having to be at 
the system to confirm overwrites
Comment 1 Bernhard Rosenkraenzer 2002-02-19 07:44:45 EST
By any chance, did you alias cp="cp -i"? That's the default setup for root, and will cause 
precisely this behavior.
Comment 2 Kevin Moore 2002-02-19 08:15:17 EST
Aliasing appears to have been the problem. 
Thanks for the quick feedback.

Kevin Moore
Engineering Manager
The Durham Company
Comment 3 Bernhard Rosenkraenzer 2002-02-19 09:06:42 EST
Ok, not a bug then.

Note You need to log in before you can comment on or make changes to this bug.