Bug 600177 - KDE does not start due to ksmserver problem
KDE does not start due to ksmserver problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
13
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 01:38 EDT by George
Modified: 2010-06-11 02:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 02:52:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George 2010-06-04 01:38:40 EDT
Description of problem:
KDE does not start due to ksmserver problem

Version-Release number of selected component (if applicable):
Most up to date KDE rpms

How reproducible:
Always

Steps to Reproduce:
1. startx
2.
3.
  
Actual results:
X does not start

Expected results:
X should start

Additional info:

RPMs from fc12 work OK

r Brightness Down" for "kded" : "Decrease Screen Brightness"
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QObject::connect: Cannot connect (null)::accessibilityChanged(bool, const QString) to DeviceAutomounter::deviceMountChanged(bool, const QString)
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was
':1.6'
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kcminit_startup.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_ksmserver.so
<unknown program name>(2777)/ KStartupInfo::createNewStartupId: creating:  "numpty;1275625353;28509;2777_TIME0" : "unnamed app"
ksmserver: symbol lookup error: /usr/lib/libGL.so.1: undefined symbol: _nv000136gl
startkde: Shutting down...
klauncher: Exiting on signal 1
kglobalaccel(2805) GlobalShortcutsRegistry::unregisterKey: Unregistering key "Monitor Brightness Up" for "kded" : "Increase Screen Brightness"
kglobalaccel(2805) GlobalShortcutsRegistry::unregisterKey: Unregistering key "Monitor Brightness Down" for "kded" : "Decrease Screen Brightness"
startkde: Running shutdown scripts...
startkde: Done.

waiting for X server to shut down
Comment 1 Kevin Kofler 2010-06-04 02:52:51 EDT
> ksmserver: symbol lookup error: /usr/lib/libGL.so.1: undefined symbol: _nv000136gl

Incorrectly installed or incorrectly uninstalled proprietary NVidia driver. Fix your system!
Comment 2 Rex Dieter 2010-06-05 00:38:23 EDT
To verify the contents of /usr/lib/libGL.so.1 as shipped by fedora:


$ rpm -q mesa-libGL
$ rpm -V mesa-libGL
Comment 3 George 2010-06-07 03:24:04 EDT
Hi

mesa-libGL-7.8.1-6.fc13.i686

....L....    /usr/lib/libGL.so.1

I did not have a clean upgrade to f13 the kde packages from f12 were left behind and work perfectly.  If I upgrade to the f13 packages in updates then I get the problem reported.

Thanks for looking,

George.
Comment 4 Kevin Kofler 2010-06-07 04:26:05 EDT
Well, it looks like you used the NVidia installer script from their website. (The standard Fedora libGL doesn't use any _nv* symbols.) That crappy script breaks your system. See also http://www.rpmfusion.org/RPMFusionSwitcher . If you absolutely must install NVidia's crappy proprietary drivers, at least use proper packages! See also http://www.rpmfusion.org/Howto/nVidia .
Comment 5 George 2010-06-11 02:39:19 EDT
I had used the Nvidia installer scripts a long time ago but had switched to the rpmfusion packages, however something must have been hanging around.

So I cleaned out all the rpmfusion packages and the mesa packages.  Any links/files etc that remained to anything libGL related I deleted.

I then performed a clean install starting with kmod-nvidia-PAE (depends on your kernel version) & re-installed Mesa libaries.  

Best of all after updating to kde 4.4.4 in updates-testing everything worked.

I found the following URL to be most helpful

http://fedorasolved.org/video-solutions/nvidia-yum-kmod

Hope this helps anybody with similar problems.

Cheers.....

Note You need to log in before you can comment on or make changes to this bug.