This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 60019 - swallowed apps don't anymore
swallowed apps don't anymore
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-18 23:22 EST by Bill Nottingham
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-21 00:11:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2002-02-18 23:22:00 EST
This worked in 0.38-11; it broke when we went to the 1.0.x series.

I have, in my default panel config, the following:

[Applet_19]
id=Swallow
parameters=Dali Clock
execpath=xdaliclock -fn 10x20 -geometry 120x24 -cycle
width=120
height=24
position=851
panel=0
unique_panel_id=1856552961
right_stick=true

With sawfish-1.0.1-3, the applet itself is blank, and the clock appears in the
middle of the screen. Something about the window properties confuses sawfish;
if I maximize a window while the clock is running, it only fills the screen to
the top of the clock.
Comment 1 Bill Nottingham 2002-02-19 01:39:58 EST
This is caused by:

2001-08-24  John Harper  <jsh@pixelslut.com>

        * events.c (unmap_notify): call remove_window () on unmapped
        (withdrawn) windows. This fixes some standards-compliance bugs
        due to us handling windows differently the second time they're
        mapped than the first

Comment 2 Havoc Pennington 2002-03-01 10:31:28 EST
See http://bugzilla.gnome.org/show_bug.cgi?id=73120

closing on RH level

Note You need to log in before you can comment on or make changes to this bug.