Bug 600211 - repo for tests doesn't work well
repo for tests doesn't work well
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.5
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 03:19 EDT by Igor Zhang
Modified: 2010-07-22 16:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 16:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Zhang 2010-06-04 03:19:54 EDT
Description of problem:
repo for tests doesn't work well

How reproducible:
sometimes

Steps to Reproduce:
run complex jobs in beaker
1.
2.
3.
  
Actual results:
Some test cases cannot be found via yum repos, although they actually have been added into beaker test cases lib.

Expected results:
Test cases in rpm can be found and installed.

Additional info:
https://beaker.engineering.redhat.com/logs/2010/12/1712/3115/27154/debug/.task_beah_raw
I can find and install package rh-tests-kernel-errata-4_8-1.1-4.noarch.

https://beaker.engineering.redhat.com/logs/2010/12/1712/3115/27155/debug/.task_beah_raw
I cannot find package rh-tests-kernel-errata-4_8_z-1.1-16.noarch.

BTW, they are in the same recipe R:3115 of job https://beaker.engineering.redhat.com/jobs/1712.


Another place where I found repo didn't work:
https://beaker.engineering.redhat.com/logs/2010/77/1877/3486/30140/debug/.task_beah_raw
in recipe R:3486 of job
https://beaker.engineering.redhat.com/jobs/1877
Comment 1 Marian Csontos 2010-06-04 09:07:09 EDT
looks like a duplicate of the Bug 599424. I will fix that and retry...

Workaround: simple re-running the test should work.
Comment 2 Bill Peck 2010-07-22 16:52:05 EDT
We keep two versions of the task rpm around.  We now keep a seperate version of the repodata per recipe as well.

Note You need to log in before you can comment on or make changes to this bug.