Bug 600276 - resolutions stay in proportional when returning from mirrored mode
resolutions stay in proportional when returning from mirrored mode
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: control-center (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Control Center Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks: 599016
  Show dependency treegraph
 
Reported: 2010-06-04 06:43 EDT by Vladimir Benes
Modified: 2010-07-14 10:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 10:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2010-06-04 06:43:12 EDT
Description of problem:
I have laptop and external screens.. using both.. when I go into mirror mode the resolutions of both are altered to be the same on both screens. If I uncheck mirror screens in display preferences the resolutions are not changed back to native ones. As most of current users are using LCDs it's quite annoying to change it by hand. 

Version-Release number of selected component (if applicable):
control-center-2.28.1-18.el6.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
metacity-2.28.0-15.el6.x86_64

How reproducible:


Steps to Reproduce:
1.connect two different resolution screens
2.go into mirror mode
3.go back
  
Actual results:
no native resolution

Expected results:
screens go to native resolution

Additional info:
Comment 1 RHEL Product and Program Management 2010-06-04 07:03:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Ray Strode [halfline] 2010-07-13 13:41:45 EDT
are you still seeing this with gnome-desktop-2.28.2-7.el6 ?  I suspect this may be a duplicate of bug 582564
Comment 3 Vladimir Benes 2010-07-14 07:38:33 EDT
I've tried the bug 582564 but this is something different.

scenario:
1. obtain box with two outputs and two different sized screens
2. connect them in side to side manner (not mirror)
3. open s-c-display and click "mirror screens"
4. click apply and keep settings
5. uncheck "mirror screens" and approve the change

those monitors should go back to their native resolutions (or the resolution they had before -- native is better I think) and not the proportional ones.

versions:
control-center-2.28.1-21.el6.x86_64
gnome-desktop-2.28.2-8.el6.x86_64
Comment 4 Ray Strode [halfline] 2010-07-14 10:43:49 EDT
unfortunately, this isn't going to make the cut for GA. devnack.
Comment 5 RHEL Product and Program Management 2010-07-14 10:54:45 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.