Bug 60041 - new-kernel-pkg should never remove the last configuration from grub.conf
new-kernel-pkg should never remove the last configuration from grub.conf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
: 92255 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 05:10 EST by David Juran
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-11 00:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A quick fix for this problem (610 bytes, patch)
2002-02-19 05:11 EST, David Juran
no flags Details | Diff

  None (edit)
Description David Juran 2002-02-19 05:10:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020211

Description of problem:
The script new-kernel-pkg should never remove the last configuration from
grub.conf. This will leave your system in a state where grubby can't be used to
insert a new one since it doesn't have any templates

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. do rpm -e on every kernel you have
2. Try to do rpm -i on a new kernel package
3.
	

Actual Results:  grubby will complain that it doesn't have any templates and
won't fix your grub.conf

Expected Results:  The new kernel should be inserted into grub.conf

Additional info:
Comment 1 David Juran 2002-02-19 05:11:34 EST
Created attachment 45960 [details]
A quick fix for this problem
Comment 2 Jeremy Katz 2003-03-20 12:46:59 EST
Reassigning
Comment 3 Jeremy Katz 2003-06-10 23:53:15 EDT
*** Bug 92255 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2003-06-11 00:12:18 EDT
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.