Bug 600547 - authconfig does not configure for ldap
Summary: authconfig does not configure for ldap
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-05 00:30 UTC by Russell Miller
Modified: 2010-06-07 07:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 07:00:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell Miller 2010-06-05 00:30:33 UTC
Description of problem:

on a base install, authconfig will not configure for ldap under 13.  Does under 12.

The ldap.conf file (which I can provide if needed) works just fine under 12.  An identical one under 13 does not.  

On further investigation authconfig drops some pam_ldap stuff into the pam.d files under 12, and doesn't do so under 13.

Version-Release number of selected component (if applicable):

6.1.4-2

How reproducible:

Always

Steps to Reproduce:
1.  Run authconfig --enableshadow --enablemd5 --enablemkhomedir --enableldap --enableldapauth --enablelocauthorize --enablesysnetauth --enablesssd --updateall
2. Watch the pam files NOT get configured for ldap, and sssd isn't configured right either.
3. A similar command (minus the 13 specific stuff) works just fine in Fedora 12.


  
Actual results:

ldap doesn't work.

Expected results:

ldap works.

Additional info:

Let me know if you need config files.

Comment 1 Tomas Mraz 2010-06-07 07:00:51 UTC
This is by design. Authconfig currently prefers SSSD instead of the pam_ldap.

Also you must not use --enablesssd if you do not want to configure the sssd.conf manually.


Note You need to log in before you can comment on or make changes to this bug.