Bug 600609 - KVM-rhel3u9 installed virtio driver is converted to IDE after conversion
Summary: KVM-rhel3u9 installed virtio driver is converted to IDE after conversion
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-05 07:34 UTC by Rita Wu
Modified: 2013-07-03 01:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 10:58:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from LIBGUESTFS_TRACE=1 (9.68 KB, text/plain)
2010-06-05 07:34 UTC, Rita Wu
no flags Details
log from virt-inspect before conversion (306.07 KB, text/plain)
2010-06-05 07:39 UTC, Rita Wu
no flags Details

Description Rita Wu 2010-06-05 07:34:59 UTC
Created attachment 421406 [details]
log from LIBGUESTFS_TRACE=1

Description of problem:
The source KVM guest rhel3u9 is installed with virtio driver, but after conversion, it will become IDE (network and block).

Before conversion info in guest:
# lspci
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II]
00:01.2 USB Controller: Intel Corporation 82371SB PIIX3 USB [Natoma/Triton II] (rev 01)
00:01.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:02.0 VGA compatible controller: Cirrus Logic GD 5446
00:03.0 Ethernet controller: Unknown device 1af4:1000
00:04.0 SCSI storage controller: Unknown device 1af4:1001
00:05.0 RAM memory: Unknown device 1af4:1002
[root@localhost root]# lsmod |grep virtio
virtio_pci              6024   1 
virtio_ring             2892   0  [virtio_pci]
virtio_blk             28944   3 
virtio_net             10440   2 
virtio                  3692   0  [virtio_pci virtio_blk virtio_net]
# cat /etc/modules.conf
alias eth0 virtio_net
 


After conversion info in guest:
# lspci
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 RAM memory: Unknown device 1af4:0200
00:01.2 IDE interface: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II]
00:01.3 USB Controller: Intel Corporation 82371SB PIIX3 USB [Natoma/Triton II] (rev 01)
00:01.4 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:02.0 VGA compatible controller: Cirrus Logic GD 5446
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 03)
# lsmod |grep virtio
# cat /etc/modules.conf
alias eth0 e1000


Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-3.el5

How reproducible:
always

Steps to Reproduce:
1.#virt-v2v -f /etc/virt-v2v.conf -i libvirtxml -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export virtio-rhel39-32.xml
virt-v2v: No capability in config matches os='linux' name='virtio' distro='rhel' major='3' minor='9'
virt-v2v: rhel39-32 configured without virtio drivers 




  
Actual results:
after conversion, it will become IDE

Expected results:
rhel3u9 remain virtio

Additional info:
# cat virtio-rhel39-32.xml 
<domain type='kvm' id='5'>
  <name>rhel39-32</name>
  <uuid>4543fd70-79d0-b74f-ded7-3cb394a49f52</uuid>
  <memory>524288</memory>
  <currentMemory>524288</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='rhel5.4.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' cache='none'/>
      <source file='/media/disk-1/cleankvm/raw/RHEL-3.9-32-virtio.raw'/>
      <target dev='vda' bus='virtio'/>
    </disk>
    <interface type='network'>
      <mac address='54:52:00:3f:2f:01'/>
      <source network='default'/>
      <model type='virtio'/>
      <target dev='vnet0'/> 
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/12'/>
      <target port='0'/>
    </serial>
    <console type='pty' tty='/dev/pts/12'>
      <source path='/dev/pts/12'/>
      <target port='0'/>
    </console>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5900' autoport='yes' keymap='en-us'/>
  </devices>
</domain>

Comment 1 Rita Wu 2010-06-05 07:39:58 UTC
Created attachment 421407 [details]
log from virt-inspect before conversion

Comment 3 RHEL Product and Program Management 2010-08-09 19:11:56 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 Matthew Booth 2011-02-01 10:58:07 UTC
RHEL 3 is out of support, and the way virtio 'worked' in RHEL 3 was so hokey as to be unsupportable anyway.


Note You need to log in before you can comment on or make changes to this bug.