Bug 60062 - Internal compiler error in build_insn_chain
Summary: Internal compiler error in build_insn_chain
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-19 16:37 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 19:25:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source file causing compiler bug problem (6.29 KB, text/plain)
2002-03-06 20:59 UTC, Need Real Name
no flags Details
compiled as gcc -c -save-temps xwmain.c (139.50 KB, text/plain)
2002-03-07 14:56 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-02-19 16:37:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-21 i686)

Description of problem:
Internal compiler error in build_insn_chain, at global.c:1857

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.gcc -c xwmain.c
2.
3.
	

Actual Results:  xwmain.c: In function `main':
xwmain.c:195: Internal compiler error in build_insn_chain, at global.c:1857
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Expected Results:  normal compile.  worked in linux 6.2 with gcc 3.0.2 on a
pentium mmx 

Additional info:

currently using gcc 3.0.3 on an AMD duron

Comment 1 Need Real Name 2002-02-25 21:19:17 UTC
Determined that the version of gcc being run was incorrect, since the 3.0.3 install does not overwrite the earlier versions of gcc in /usr/lib, rather 
puts the new commands in /usr/local/lib.

The program compiles without errors using gcc version 2.91.66 running in RedHat version 6.2
The program compiles with the above error using gcc version 2.96 running in RedHat version 7.2
The program compiles with the above error using gcc version 3.0.3 running in RedHat version 7.2 or 6.2

Comment 2 Jakub Jelinek 2002-03-06 20:45:29 UTC
Can you attach xwmain.i (just run gcc -c -save-temps xwmain.c)?

Comment 3 Need Real Name 2002-03-06 20:59:22 UTC
Created attachment 47640 [details]
source file causing compiler bug problem

Comment 4 Jakub Jelinek 2002-03-07 10:51:48 UTC
Source file is useless, because I don't have the headers.
Can you attach xwmain.i (either run gcc -c -save-temps xwmain.c,
or gcc -E xwmain.c -o xwmain.i) please?

Comment 5 Need Real Name 2002-03-07 14:56:19 UTC
Created attachment 47740 [details]
compiled as   gcc -c -save-temps xwmain.c

Comment 6 Alan Cox 2002-12-15 19:25:29 UTC
Verified 3.2 doesnt crash on this



Note You need to log in before you can comment on or make changes to this bug.