Bug 600746 - Fix ADL anonymous type crash
Fix ADL anonymous type crash
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdb (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Kratochvil
Petr Muller
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-05 16:57 EDT by Jan Kratochvil
Modified: 2016-09-19 22:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: gdb-7.1-25.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:26:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2010-06-05 16:57:33 EDT
Description of problem:
There is a crash regression against RHEL-5.

Version-Release number of selected component (if applicable):
gdb-7.1-24.fc13

How reproducible:
Always.

Steps to Reproduce:
runtest gdb.cp/koenig.exp # that is:
#test that lookup is not thwarted by anonymous types
gdb_test "p foo (p_union)" "Cannot resolve function foo to any overloaded instance"

Actual results:
ERROR: Process no longer exists

Expected results:
PASS: gdb.cp/koenig.exp: p foo (p_union)

Additional info:
There are more patches to make it working but the intended one is only to fix a crash.

Upstream fix:
http://sourceware.org/ml/gdb-patches/2010-06/txt00000.txt
http://sourceware.org/ml/gdb-cvs/2010-06/msg00012.html

devel_ack:
There is no regression risk, just one new NULL check.

qa_ack:
New testcase:
PASS: gdb.cp/koenig.exp: p foo (p_union)
Comment 1 RHEL Product and Program Management 2010-06-05 17:02:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Fedora Update System 2010-06-09 09:59:00 EDT
gdb-7.1-26.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdb-7.1-26.fc13
Comment 3 Fedora Update System 2010-06-10 15:22:48 EDT
gdb-7.1-26.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Petr Muller 2010-08-03 10:53:01 EDT
# runtest --tool=gdb gdb.cp/namespace-koenig.exp; grep p_union gdb.log
(...)
p foo (p_union)
(gdb) PASS: gdb.cp/namespace-koenig.exp: p foo (p_union)
Comment 6 releng-rhel@redhat.com 2010-11-10 15:26:44 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.