Bug 60077 - Split screen mode not available in this build
Split screen mode not available in this build
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 14:33 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 16:23:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-19 14:33:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011229

Description of problem:
Split screen mode, visual (v highlights text as it is moved over for a
selection), are not available.  an attempt to split returns the error message
"E319: Sorry, the command is not available in this version"

I know I've been meaning to learn emacs, but this is an extreme way to encourage
the idea. :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start vim
2.type ":split<ENTER."
3.observe message.
	

Expected Results:  Screen would split into two windows

Additional info:

GVIM works as expected.

Package information from my install:

Name        : vim-minimal                  Relocations: (not relocateable)
Version     : 6.0                               Vendor: Red Hat, Inc.
Release     : 7.13                          Build Date: Mon 28 Jan 2002 03:10:38
AM PST
Install date: Sun 17 Feb 2002 08:28:51 PM PST      Build Host:
stripples.devel.redhat.com
Group       : Applications/Editors          Source RPM: vim-6.0-7.13.src.rpm
Size        : 387820                           License: freeware
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : A minimal version of the VIM editor.
Description :
VIM (VIsual editor iMproved) is an updated and improved version of the
vi editor.  Vi was the first real screen-based editor for UNIX, and is
still very popular.  VIM improves on vi by adding new features:
multiple windows, multi-level undo, block highlighting and more.
Comment 1 Bernhard Rosenkraenzer 2002-02-19 15:02:11 EST
Don't. Emacs is a horribly broken piece of shit (almost as bad as that other Operating 
System ;) ). 
 
vim-minimal is designed to be minimalistic though. You want to install the vim-enhanced 
package.
Comment 2 Need Real Name 2002-02-19 15:39:22 EST
Ah, yes, the enhanced as in:

[mikeraz@daemon mikeraz]$ rpm -qa | grep vim
vim-X11-6.0-7.13
vim-enhanced-6.0-7.13
vim-minimal-6.0-7.13
vim-common-6.0-7.13
[mikeraz@daemon mikeraz]$

Still not working, and sorry to say I didn't report it this way to begin with.

To be certain I didn't stomp on myself.  Uninstalled all, reinstalled all but
the vim-minimal package.  As in: 

`rpm -ivh vim-common-6.0-7.13.i386.rpm  vim-enhanced-6.0-7.13.i386.rpm
vim-X11-6.0-7.13.i386.rpm`

still no split windows, and I really like them.  And I can't do gvim while sshed
in from work.

Emacs a "horribly broken piece of ... Other operating system"?  Like debian or
Mandrake?  No you must mean AmigaDOS.  Gad and I just remapped the Caps Lock key
to CTRL and bought the O'Reilly book and was wondering "nmeonics?  didn't the
designers ever hear of nmeonics?  Oh, wait!  There are a couple.  gee thanks."  :)

Comment 3 Bernhard Rosenkraenzer 2002-02-19 16:23:34 EST
This is odd, I'm using those features every day and I'm not having any problems. 
(Btw: You may also want to try :vsplit - it's a new feature in 6.0 and I tend to find it 
even more useful than :split). 
 
If you type just vim without a filename, which version is indicated? 
Does it work if you invoke it as "/usr/bin/vim" rather than just vi or vim? (Just trying 
to make sure it's not an alias or something messing up).
Comment 4 Need Real Name 2002-02-19 17:10:05 EST
In the interest of full disclosure:


[mikeraz@daemon mikeraz]$ which vim
/bin/vim
[mikeraz@daemon mikeraz]$ alias
...
alias vi='vim'

[mikeraz@daemon mikeraz]$ locate vim | grep vim$ | grep bin
/usr/bin/rvim
/usr/bin/vim
/usr/share/doc/vim-common-6.0/syntax/bindzone.vim
/usr/share/vim/vim60/syntax/bindzone.vim
/usr/X11R6/bin/evim
/usr/X11R6/bin/gvim
/bin/vim
[mikeraz@daemon mikeraz]$

Hmmm, what's this?  a /usr/bin/vim and a /bin/vim ??

/usr/bin/vim  :: Work as hoped for/expected
/bin/vim :: crippled.

So is this a bug of vim-minimal not deleting /bin/vim on uninstall?
I don't know/care.  RH may have an interest.
/bin/vim not owned by any package (freshly installed system, sheesh)
rpm -qf -p shows that vim-minimal has many /bin entries but vi not vim...

worksforme

fun:

:split
:vsplit
<CTRL>WW
<CTRL>WW
:vsplit


Thanks for the help.

Note You need to log in before you can comment on or make changes to this bug.