Bug 60094 - XFree86 package doesn't have all dependencies
XFree86 package doesn't have all dependencies
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 60393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 17:28 EST by Ed Avis
Modified: 2007-04-18 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 08:09:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2002-02-19 17:28:32 EST
XFree86-4.1.0-15.i386.rpm depends on libncurses.so.5 (for xterm), but this is
not listed as a dependency of the package.  Perhaps this indicates a fault with
rpm's FindRequires mechanism.
Comment 1 Mike A. Harris 2002-02-22 04:40:55 EST
ncurses is in the list for 4.1.0-3, I'll have to check 4.1.0-15 though

pts/22 mharris@zod:~$ rpm -qf /usr/X11R6/bin/xterm
XFree86-4.1.0-3
pts/22 mharris@zod:~$ rpm -q --requires XFree86-4.1.0-3
XFree86-xfs = 4.1.0
XFree86-libs = 4.1.0
/etc/pam.d/system-auth
kernel-drm = 4.1.0
/bin/ln
/usr/sbin/chkfontpath
/usr/X11R6/bin/mkfontdir
Mesa >= 3:3.4.2-7
rpmlib(VersionedDependencies) <= 3.0.3-1
/bin/sh
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
ld-linux.so.2
libc.so.6
libdl.so.2
libdps.so.1
libfreetype.so.6
libICE.so.6
libm.so.6
libncurses.so.5
libpam_misc.so.0
libpam.so.0
libSM.so.6
libutempter.so.0
libX11.so.6
libXaw3d.so.7
libXaw.so.7
libXext.so.6
libXfont.so.1
libXft.so.1
libXIE.so.6
libXi.so.6
libXmu.so.6
libXmuu.so.1
libXpm.so.4
libXrender.so.1
libXt.so.6
libXtst.so.6
libz.so.1
libglide3.so.3
libGL.so.1
/bin/sh
/usr/bin/perl
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libm.so.6(GLIBC_2.0)
Comment 2 Mike A. Harris 2002-02-22 04:45:08 EST
i386$ rpm -qp --requires XFree86-4.1.0-15.i386.rpm
XFree86-xfs = 4.1.0
XFree86-libs = 4.1.0
/etc/pam.d/system-auth
kernel-drm = 4.1.0
/bin/ln
/usr/sbin/chkfontpath
/usr/X11R6/bin/mkfontdir
Mesa >= 3:3.4.2-7
rpmlib(VersionedDependencies) <= 3.0.3-1
/bin/sh
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/sh
/usr/bin/perl
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libm.so.6(GLIBC_2.0)

Hmm.  Indeed, there is a difference.  I'm not at all sure what is going
on here, but it looks like either an rpm bug, or a buildsystem glitch,
and an unfortunate one at that.  Time to consult with Jedi Buildmaster
Johnson on this one...  jbj, what do you think?
Comment 3 Mike A. Harris 2002-02-22 21:36:53 EST
Nothing is going on with XFree86 or the XFree86 packaging that is out
of the ordinary here.  I'm reassigning this bug to rpm for now.  If it is
not a bug in rpm, then it must have been transient failure of the build
system.
Comment 4 Jeff Johnson 2002-02-24 11:27:10 EST
The following command shows this is not an rpm
find-requires problem:
   bash$ echo /usr/X11R6/bin/xterm | /usr/lib/rpm/find-requires | grep curses
   libncurses.so.5
Comment 5 Ed Avis 2002-02-24 11:30:15 EST
Just guessing - maybe /usr/X11R6/bin/ is not being searched for dependencies
although /usr/bin/ etc. are.
Comment 6 Mike A. Harris 2002-02-24 11:34:06 EST
Here is the current RPM from rawhide

$ rpm -qp --requires XFree86-4.2.0-6.35.i386.rpm
Glide3
XFree86-xfs = 4.2.0
XFree86-libs = 4.2.0
XFree86-base-fonts = 4.2.0-6.35
/etc/pam.d/system-auth
kernel-drm = 4.2.0
/bin/ln
/usr/sbin/chkfontpath
/usr/X11R6/bin/mkfontdir
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
ld-linux.so.2
libc.so.6
libdl.so.2
libdps.so.1
libfreetype.so.6
libICE.so.6
libm.so.6
libncurses.so.5
libpam_misc.so.0
libpam.so.0
libSM.so.6
libutempter.so.0
libX11.so.6
libXaw3d.so.7
libXaw.so.7
libXext.so.6
libXfont.so.1
libXft.so.1
libXi.so.6
libXmu.so.6
libXmuu.so.1
libXpm.so.4
libXrandr.so.1
libXrender.so.1
libXt.so.6
libXtst.so.6
libz.so.1
libGL.so.1
/bin/sh
/usr/bin/perl
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libm.so.6(GLIBC_2.0)
Comment 7 Mike A. Harris 2002-02-24 11:35:40 EST
$ rpm -qp --requires 4.1.0-4/i386/XFree86-4.1.0-4.i386.rpm
XFree86-xfs = 4.1.0
XFree86-libs = 4.1.0
/etc/pam.d/system-auth
kernel-drm = 4.1.0
/bin/ln
/usr/sbin/chkfontpath
/usr/X11R6/bin/mkfontdir
Mesa >= 3:3.4.2-7
rpmlib(VersionedDependencies) <= 3.0.3-1
/bin/sh
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
ld-linux.so.2
libc.so.6
libdl.so.2
libdps.so.1
libfreetype.so.6
libICE.so.6
libm.so.6
libncurses.so.5
libpam_misc.so.0
libpam.so.0
libSM.so.6
libutempter.so.0
libX11.so.6
libXaw3d.so.7
libXaw.so.7
libXext.so.6
libXfont.so.1
libXft.so.1
libXIE.so.6
libXi.so.6
libXmu.so.6
libXmuu.so.1
libXpm.so.4
libXrender.so.1
libXt.so.6
libXtst.so.6
libz.so.1
libglide3.so.3
libGL.so.1
/bin/sh
/usr/bin/perl
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libm.so.6(GLIBC_2.0)
Comment 8 Ed Avis 2002-02-24 11:37:37 EST
I wonder what happens if you rebuild the source package
XFree86-4.1.0-15.i386.src.rpm?  Pretty sure it will be just fine like the
Rawhide one, and no help in tracking down the bug :-(.

Comment 9 Mike A. Harris 2002-02-24 11:47:02 EST
I have checked every release of XFree86 that exists on porkchop, including
intermediate builds.  The _only_ build that fails to include proper
dependancy information is 4.1.0-15.  All other versions including -3, -4,
-7, -8, -9, -10, -11, -12, -13, -14, -18, and -16 for alpha, all have
proper dependancy information.  A rebuilt -15 I made locally also contains
proper deps.

It seems clear to me that find-requires for some reason or another did not
get ran when this RPM package was built.  Nothing caught this error in rpm,
nor in the buildsystem, nor human intervention.

I'm not sure how rpm, beehive, or anyone could have really caught this
problem, but I do know that these RPM's were built, and releases just
prior to us discovering some of the buildsystem breakage.

Since the bug is obviously a transient build system breakage, and new RPM's
do not have this problem, I am closing it as fixed in rawhide.

We should consider investigating how to detect such a failure in an automated
way perhaps in the future, and add the test to all packages built.
No idea how realistically possible it is to implement though.
Comment 10 Mike A. Harris 2002-02-24 11:49:59 EST
And I just closed this rawhide, and bugzilla is not showing RAWHIDE as
the resolution.  I've CC'd dkl to have a look.
Comment 11 Alexei Podtelezhnikov 2002-02-25 21:55:46 EST
Shall we see the proper XFree86-4.1.0-18 in ftp://people.redhat.com/mharris ?
Comment 12 Mike A. Harris 2002-02-27 17:27:52 EST
*** Bug 60393 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.