Bug 601079 - Boot fails with LVM logging to file and / not on LV
Boot fails with LVM logging to file and / not on LV
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: Milan Broz
Corey Marthaler
: Regression, ZStream
: 603088 (view as bug list)
Depends On: 592967
Blocks: 556823
  Show dependency treegraph
 
Reported: 2010-06-07 03:52 EDT by RHEL Product and Program Management
Modified: 2013-02-28 23:09 EST (History)
18 users (show)

See Also:
Fixed In Version: lvm2-2.02.56-8.el5_5.5
Doc Type: Bug Fix
Doc Text:
The lvm command used to fail when the log file specified in lvm.conf was not available. This problem is now resolved and the commands simply log the error and continue as if there was no log file specified at all
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 03:16:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0510 normal SHIPPED_LIVE lvm2 bug fix update 2010-07-08 03:16:14 EDT

  None (edit)
Description RHEL Product and Program Management 2010-06-07 03:52:45 EDT
This bug has been copied from bug #592967 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 4 Milan Broz 2010-06-07 06:48:36 EDT
Fixed in lvm2-2.02.56-8.el5_5.5.
Comment 10 Milan Broz 2010-06-11 10:29:28 EDT
*** Bug 603088 has been marked as a duplicate of this bug. ***
Comment 11 Debbie Johnson 2010-06-15 12:09:31 EDT
Wait a second ...  the customer is using the lvm that you state fixes this issue.

Since lvm2-2.02.56-8.el5, LVM commands do not accept a non-writable log file [ lvm.conf : log { file = "/var/log/lvm2.log" } ]
Any command will refuse to process.
Unfortunately, the result is that LVM will fail VG activation during boot as root is still read-only during activation.

The boot process works fine if the file = "/var/log/lvm2.log" is commented out.

NOTE:  I have reproduced this issue on RHEL6.


Debbie
Comment 12 Debbie Johnson 2010-06-15 12:16:11 EDT
Apologize..  did not notice the _5.5 at the end of the package name..

lvm2-2.02.56-8.el5_5.5


Still question though.. has this been fixed in RHEL6 or does a new BZ need to be opened since I duplicated the issue there?

Thanks,

Debbie
Comment 14 Milan Broz 2010-06-17 09:20:59 EDT
(In reply to comment #12)
> Still question though.. has this been fixed in RHEL6 or does a new BZ need to
> be opened since I duplicated the issue there?

For RHEL6 - probably not yet fixed in current build, but there will be another build including all these upstream patches.
Comment 17 errata-xmlrpc 2010-07-08 03:16:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0510.html
Comment 18 Florian Nadge 2010-07-14 06:13:57 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
The lvm command used to fail when the log file specified in lvm.conf was not available. This problem is now resolved and the commands simply log the error and continue as if there was no log file specified at all

Note You need to log in before you can comment on or make changes to this bug.