Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601193 - can't print on wlan printer, although installation worked fine
can't print on wlan printer, although installation worked fine
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 606405 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 08:45 EDT by Frank
Modified: 2010-06-24 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-24 11:27:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the "advanced" diagnose output from printer preferences after trying to print test page (101.93 KB, text/plain)
2010-06-07 08:45 EDT, Frank
no flags Details

  None (edit)
Description Frank 2010-06-07 08:45:31 EDT
Created attachment 421810 [details]
This is the "advanced" diagnose output from printer preferences after trying to print test page

Description of problem:
Might  not be a cups problem? I installed a Brother DCP585CW printer per WLAN. The installation went without problems using the drivers from brother (dcp585cwlpr-1.1.2-2.i386 dcp585cwcupswrapper-1.1.2-2.i386), printer is looking fine. When attempting to print something, documents get not printed. See attached error log and troubleshoot.txt from the diagnose tool.

Both installation *and* printing per WLAN work perfectly fine on another F13 system in the same wireless network.


Version-Release number of selected component (if applicable):
cups-1.4.3-6.fc13.i686

How reproducible:
always

Steps to Reproduce:
1. try to print something
2.
3.
  
Actual results:
doesn't print

Expected results:
should print

Additional info:
Comment 1 Jiri Popelka 2010-06-07 10:39:01 EDT
I see these two interesting lines in error_log:
'D [07/Jun/2010:14:14:01 +0200] [Job 19] /usr/local/Brother/Printer/dcp585cw/lpd/filterdcp585cw: line 57: a2ps: command not found',
'D [07/Jun/2010:14:14:01 +0200] [Job 19] /usr/bin/gs: error while loading shared libraries: libtiff.so.3: failed to map segment from shared object: Permission denied',

The first 'a2ps: command not found' problem can probably be fixed by installing  a2ps (yum install a2ps).
The second line indicates some problem with access to libtiff.
You can try to reinstall libtiff (yum reinstall libtiff) or
restore SELinux context (/sbin/restorecon /usr/lib/libtiff.so.3).

Let me know if that changes something.
Comment 2 Frank 2010-06-07 14:11:43 EDT
a2ps is now installed, but the libtiff error still persists. I tried both reinstallation and restorecon. No effect.
Comment 3 Frank 2010-06-15 03:19:47 EDT
I should mention that after submitting a job, I can see on the printer's display that the connection is established for a short time. So cups is sending something...
Comment 4 Tim Waugh 2010-06-22 04:42:19 EDT
Does 'ausearch -c gs' or 'ausearch -m AVC' show any audit messages relating to this?  Does the problem persist after setting SELinux to permissive mode with 'setenforce 0'?
Comment 5 Tim Waugh 2010-06-22 04:42:28 EDT
*** Bug 606405 has been marked as a duplicate of this bug. ***
Comment 6 Frank 2010-06-22 12:33:31 EDT
After setenforce 0, printing works fine! Problem reappears with setenforce 1. So it seems to be a selinux problem.

I can't find ausearch on my system. Which package would I need to install for ausearch?
Comment 7 Tim Waugh 2010-06-23 09:33:30 EDT
It's in the audit package.  If you don't have it installed, try 'dmesg' to see if there are any avc messages.  Otherwise, install audit -- and you might have to reboot or start the auditd service or something -- and then try printing again, and then try ausearch.
Comment 8 Frank 2010-06-24 03:24:55 EDT
There is something:

ausearch -c gs 

time->Thu Jun 24 09:19:05 2010
type=SYSCALL msg=audit(1277363945.319:27): arch=40000003 syscall=192 success=no exit=-13 a0=2fac000 a1=4b8a0 a2=5 a3=802 items=0 ppid=2136 pid=2165 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm="gs" exe="/usr/bin/gs" subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1277363945.319:27): avc:  denied  { execute } for  pid=2165 comm="gs" path="/opt/eInstruction/Interwrite_Workspace/screen_capture/lib/libtiff.so.3.6" dev=sda5 ino=247376 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=file

ausearch -m AVC

time->Thu Jun 24 09:19:03 2010
type=SYSCALL msg=audit(1277363943.282:26): arch=40000003 syscall=192 success=no exit=-13 a0=0 a1=4b8a0 a2=5 a3=802 items=0 ppid=1130 pid=2081 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm="bannertops" exe="/usr/lib/cups/filter/bannertops" subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1277363943.282:26): avc:  denied  { execute } for  pid=2081 comm="bannertops" path="/opt/eInstruction/Interwrite_Workspace/screen_capture/lib/libtiff.so.3.6" dev=sda5 ino=247376 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=file
----
time->Thu Jun 24 09:19:05 2010
type=SYSCALL msg=audit(1277363945.319:27): arch=40000003 syscall=192 success=no exit=-13 a0=2fac000 a1=4b8a0 a2=5 a3=802 items=0 ppid=2136 pid=2165 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm="gs" exe="/usr/bin/gs" subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1277363945.319:27): avc:  denied  { execute } for  pid=2165 comm="gs" path="/opt/eInstruction/Interwrite_Workspace/screen_capture/lib/libtiff.so.3.6" dev=sda5 ino=247376 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=file
Comment 9 Tim Waugh 2010-06-24 08:55:20 EDT
Seems like you have a system-wide ld.so path, perhaps set in /etc/ld.so.conf.d/* somewhere, for some non-system libtiff.  And perhaps that non-system libtiff has incorrect SELinux tags?

What is that libtiff.so.3.6?  Where did it come from?  How/why is it in the ld.so path for the whole system?
Comment 10 Frank 2010-06-24 09:58:45 EDT
Oh, now I see it. I didn't look closely at this output first because I don't know much about selinux anyway. The system tries to access a non-system libtiff, which, as I assume from the path, has been installed with a software that I used for connecting to an electronic whiteboard. Should not be in the path for the whole system, though. I'll try to fix that up later today when I'll have access to that machine.
Comment 11 Frank 2010-06-24 11:27:14 EDT
I moved the wrong libtiff out of the way, and cups now accesses the correct system version of libtiff. Printing works fine now.

I realize that was not a Fedora bug, but caused only by that weird software I has installed. Sorry for keeping people busy, and thanks a lot for your help!

Closed.

Note You need to log in before you can comment on or make changes to this bug.