Bug 601195 - ahci power saving change may result in failure to identify disks
ahci power saving change may result in failure to identify disks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity urgent
: rc
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 08:57 EDT by Matthew Garrett
Modified: 2013-01-10 02:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:13:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix this (2.16 KB, patch)
2010-06-07 09:02 EDT, Matthew Garrett
no flags Details | Diff

  None (edit)
Description Matthew Garrett 2010-06-07 08:57:17 EDT
Bugzilla 577967 added code for powering down ahci DMA engines if there's no device attached. This appears to occasionally result in a failure to identify devices and a consequent failure to boot.
Comment 1 Matthew Garrett 2010-06-07 09:02:26 EDT
Created attachment 421812 [details]
Patch to fix this
Comment 3 RHEL Product and Program Management 2010-06-07 09:33:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Matthew Garrett 2010-06-09 16:36:57 EDT
Posted on June 9th.
Comment 6 Aristeu Rozanski 2010-07-01 12:22:30 EDT
Patch(es) available on kernel-2.6.32-42.el6
Comment 9 Mike Gahagan 2010-09-02 13:27:34 EDT
We've booted numerous snapshots since Beta on AHCI systems. Additionally setting of link power has not affected subsequent boots or devices already attached on any of the systems I've tested AHCI link power management on. 

Hotplugged devices are the exception where link power management has to be set to max_performance in order for device detection to work. The kernel should disallow this on any hotpluggable SATA port already.
Comment 10 releng-rhel@redhat.com 2010-11-11 11:13:56 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.