Bug 601243 - panel not fully redrawing after animation
panel not fully redrawing after animation
Status: CLOSED DUPLICATE of bug 571785
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 10:37 EDT by Issue Tracker
Modified: 2010-06-08 15:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 15:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of panel (348.27 KB, image/png)
2010-06-07 10:38 EDT, Kent Baxley
no flags Details

  None (edit)
Description Issue Tracker 2010-06-07 10:37:04 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-06-07 10:37:05 EDT
Event posted on 06-07-2010 10:14am EDT by woodard

Description of problem:
After the X bug that caused all sorts of redraw problems for text input boxes and certain buttons was fixed, a new problem started showing up with panels that hide or slip to the side. 

The one on the top can be slipped to the left or right and as it unfurls it Doesn't draw properly and leaves remnants of the animation. Moving the cursor over application buttons and activating menus redraws that section but most of the panel remains improperly drawn.

On the lower panel it auto-hides and when it comes up it is all black. However moving over the application icons in the panel causes them to redraw. 

How reproducible:
always

Additional info:

[ben@snog Desktop]$ rpm -qa | grep panel
gnome-panel-libs-2.28.0-22.el6.x86_64
gnome-panel-2.28.0-22.el6.x86_64
libpanelappletmm-2.26.0-2.1.el6.x86_64
[ben@snog Desktop]$ rpm -qa | grep xorg
xorg-x11-drv-vesa-2.3.0-1.el6.x86_64
xorg-x11-drv-tdfx-1.4.3-1.1.el6.x86_64
xorg-x11-drv-trident-1.3.3-1.1.el6.x86_64
xorg-x11-drv-hyperpen-1.3.0-4.el6.x86_64
xorg-x11-drv-i128-1.3.3-1.1.el6.x86_64
xorg-x11-drv-savage-2.3.1-1.1.el6.x86_64
xorg-x11-apps-7.4-10.el6.x86_64
xorg-x11-font-utils-7.2-10.el6.x86_64
xorg-x11-drv-siliconmotion-1.7.3-1.1.el6.x86_64
xorg-x11-drv-wacom-0.10.5-3.el6.x86_64
xorg-x11-drv-glint-1.2.4-1.1.el6.x86_64
xorg-x11-server-common-1.7.7-4.el6.x86_64
xorg-x11-drv-fbdev-0.4.1-1.1.el6.x86_64
xorg-x11-drv-keyboard-1.4.0-3.el6.x86_64
xorg-x11-drv-nouveau-0.0.16-6.20100423git13c1043.el6.x86_64
xorg-x11-server-Xorg-1.7.7-4.el6.x86_64
xorg-x11-proto-devel-7.4-35.el6.noarch
xorg-x11-drv-ati-6.13.0-4.el6.x86_64
xorg-x11-xauth-1.0.2-7.1.el6.x86_64
xorg-x11-drv-r128-6.8.1-2.el6.x86_64
xorg-x11-drv-openchrome-0.2.904-1.el6.x86_64
xorg-x11-drv-cirrus-1.3.2-1.1.el6.x86_64
xorg-x11-drv-sisusb-0.9.3-1.1.el6.x86_64
xorg-x11-drv-nv-2.1.15-4.el6.x86_64
xorg-x11-drv-mutouch-1.2.1-5.el6.x86_64
xorg-x11-drv-mach64-6.8.2-1.1.el6.x86_64
xorg-x11-drv-vmmouse-12.6.5-3.el6.x86_64
xorg-x11-drv-mga-1.4.12-1.el6.x86_64
xorg-x11-drv-mouse-1.5.0-4.el6.x86_64
xorg-x11-xinit-1.0.9-13.el6.x86_64
xorg-x11-xkb-utils-7.4-6.el6.x86_64
xorg-x11-drv-apm-1.2.2-1.1.el6.x86_64
xorg-x11-drv-penmount-1.4.0-5.el6.x86_64
xorg-x11-drv-rendition-4.2.2-4.1.el6.x86_64
xorg-x11-drv-ast-0.89.9-1.1.el6.x86_64
xorg-x11-drv-i740-1.3.2-1.1.el6.x86_64
xorg-x11-drv-aiptek-1.3.0-2.el6.x86_64
xorg-x11-drivers-7.3-13.2.el6.x86_64
xorg-x11-drv-qxl-0.0.12-2.1.el6.x86_64
xorg-x11-utils-7.4-7.el6.x86_64
xorg-x11-drv-voodoo-1.2.3-1.1.el6.x86_64
xorg-x11-drv-sis-0.10.2-1.1.el6.x86_64
xorg-x11-drv-s3virge-1.10.4-1.1.el6.x86_64
xorg-x11-drv-vmware-10.16.7-2.1.el6.x86_64
xorg-x11-drv-fpit-1.3.0-5.el6.x86_64
xorg-x11-drv-v4l-0.2.0-3.el6.3.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
xorg-x11-drv-ati-firmware-6.13.0-4.el6.noarch
xorg-x11-drv-void-1.3.0-4.el6.x86_64
xorg-x11-drv-acecad-1.4.0-2.el6.x86_64
xorg-x11-drv-dummy-0.3.3-1.el6.x86_64
xorg-x11-drv-elographics-1.2.3-5.el6.x86_64
xorg-x11-drv-intel-2.11.0-5.el6.x86_64
xorg-x11-drv-evdev-2.3.2-6.el6.x86_64
xorg-x11-drv-synaptics-1.2.1-3.el6.x86_64

This event sent from IssueTracker by kbaxley  [LLNL (desktop)]
 issue 986043
Comment 2 Issue Tracker 2010-06-07 10:37:07 EDT
Event posted on 06-07-2010 10:24am EDT by kbaxley

Graphics bug referred to in this issue that was fixed:

https://bugzilla.redhat.com/show_bug.cgi?id=571785


This event sent from IssueTracker by kbaxley  [LLNL (desktop)]
 issue 986043
Comment 3 Kent Baxley 2010-06-07 10:38:54 EDT
Created attachment 421844 [details]
screenshot of panel
Comment 4 RHEL Product and Program Management 2010-06-07 10:53:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Issue Tracker 2010-06-07 14:04:12 EDT
Event posted on 2010-06-07 11:04 PDT by woodard

This may be the same bug or it might be a different but. I really don't
know for sure in this case.

In this case I popped open the gnome-terminal menu, unchecked the box for
the menu then noticed that the image of the window stayed around. Then
repeated it on a slightly different portion of the window and got the same
effect. Neither of those windows are active, X just didn't tell
gnome-terminal to redraw that portion of the window. Interestingly, if I
do it near the edge of the window so that the menu covers a portion of the
desktop and gnome-terminal. The part that blocked the desktop redraws
properly, the part over the scroll bar redraws properly but the part over
the gnome-terminal doesn't redraw.

hitting crtl-l to redraw the terminal window fixes the problem. but moving
from virtual workspace to virtual workspace does not.



This event sent from IssueTracker by woodard 
 issue 986043
it_file 744023
Comment 6 Ray Strode [halfline] 2010-06-08 15:14:22 EDT
This seems like bug 571785 just isn't completely fixed yet.  That bug mentions there are people still seeing problems with the latest fixes, so I'm going to just dupe this one to that one.

*** This bug has been marked as a duplicate of bug 571785 ***

Note You need to log in before you can comment on or make changes to this bug.