Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 601248 - DeviceNotFoundError: vda
DeviceNotFoundError: vda
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: 6.0
Assigned To: Harald Hoyer
qe-baseos-daemons
anaconda_trace_hash:47e5fdf4ad3a122e5...
:
: 595522 601593 607661 (view as bug list)
Depends On:
Blocks: 510435 582286 604776 605262
  Show dependency treegraph
 
Reported: 2010-06-07 10:52 EDT by Alexander Todorov
Modified: 2018-10-27 06:45 EDT (History)
13 users (show)

See Also:
Fixed In Version: udev-147-2.20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 604776 605262 (view as bug list)
Environment:
Last Closed: 2010-11-10 16:50:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (99.86 KB, text/plain)
2010-06-07 10:52 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2010-06-07 10:52:28 EDT
The following was filed automatically by anaconda:
anaconda 13.21.50 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 161, in deviceNameToDiskByPath
    raise DeviceNotFoundError(deviceName)
  File "/usr/lib/anaconda/iw/cleardisks_gui.py", line 169, in getScreen
    ident = deviceNameToDiskByPath(d.name)
  File "/usr/lib/anaconda/gui.py", line 1415, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1336, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1473, in keyRelease
    self.nextClicked()
DeviceNotFoundError: vda
Comment 1 Alexander Todorov 2010-06-07 10:52:32 EDT
Created attachment 421848 [details]
Attached traceback automatically from anaconda.
Comment 2 Alexander Todorov 2010-06-07 10:57:29 EDT
This is with 2 disks on KVM domU.

One local disk - 1G and one iSCSI disk - 8G.
I've selected "Use all space" & "Review partitioning" then hit traceback.

The local disk is new disk image which I selected to Re-initialize. The iSCSI disk is image which was previously used for other VMs to test encrypted LVM.

Steps to reproduce:

1) Boot the installer with the local disk
2) By mistake I've selected basic storage configuration
3) Anaconda did disk scanning and asked me to re-initialize vda. I did.
4) Then went back to select specialized storage and add an iSCSI target
5) Went forward to select "Use all space". I was asked to re-initialize vda once again. I did.
Comment 3 Alexander Todorov 2010-06-07 11:25:46 EDT
Easier steps to reproduce:

1) Create 2 images to use for the virtual machine (using dd)
2) Boot the KVM guest with one of the images as local disk
3) Select specialized storage and add the other image as iSCSI disk
4) When asked select to Re-initialize all devices
5) Select Use all space and continue

Traceback.
Comment 4 David Lehman 2010-06-07 13:01:59 EDT
Udev is not creating disk/by-path symlinks for virtual disks (eg: vda).
Comment 5 Alexander Todorov 2010-06-08 03:14:50 EDT
Dave,
is this related to Bug 591970?
Comment 6 Harald Hoyer 2010-06-08 09:23:35 EDT
*** Bug 601593 has been marked as a duplicate of this bug. ***
Comment 7 Harald Hoyer 2010-06-08 09:26:28 EDT
*** Bug 595522 has been marked as a duplicate of this bug. ***
Comment 9 Alexander Todorov 2010-06-16 13:00:16 EDT
With RHEL6.0-20100615.0/Server/x86_64, udev-147-2.18.el6.x86_64.rpm ,
anaconda-13.21.50-6.el6.x86_64.rpm this is NOT fixed.

Steps to reproduce:

see comment #3. After 5) I've selected "Review partitioning layout" and got the same traceback hitting next.

In /dev/disk/by-path I don't have an entry which points to /dev/vda. There are only entries for sda.
Comment 10 Alexander Todorov 2010-06-16 14:08:23 EDT
Harald,
bug #604776 has been opened for the anaconda part of this and QE has been asked if this one can go back to ON_QA. How do we know that the udev part was fixed? 

See my previous comment about missing link for vda in /dev/disk/by-path. Isn't this what udev was supposed to fix or not?
Comment 11 Harald Hoyer 2010-06-16 15:48:46 EDT
(In reply to comment #10)
> Harald,
> bug #604776 has been opened for the anaconda part of this and QE has been asked
> if this one can go back to ON_QA. How do we know that the udev part was fixed? 
> 
> See my previous comment about missing link for vda in /dev/disk/by-path. Isn't
> this what udev was supposed to fix or not?    

yes, it really should... unless the image in the installer has an old udev.
Comment 12 Harald Hoyer 2010-06-17 06:00:01 EDT
$ grep path_id /lib/udev/rules.d/60-persistent-storage.rules |grep -q virtual || echo "correct udev version"
Comment 13 Alexander Todorov 2010-06-17 09:49:51 EDT
Harald,
the output from the command in comment #12 on both already installed system (0615.0 tree) and in stage2 anaconda is the same -> "correct udev version".

Does this mean that udev part is fixed? 

How about bug #591970, is it related?
Comment 14 David Cantrell 2010-06-17 10:22:20 EDT
That would be the problem, it seems.  We have been removing the *persistent*
udev rules files from initrd.img during image building.  It's been that way
since 2008.

We have a patch on master to address this, so anaconda-13.21.50-8 should fix
things up.
Comment 15 David Cantrell 2010-06-17 10:23:55 EDT
Cloning for anaconda, moving this back to MODIFIED.
Comment 17 Harald Hoyer 2010-06-18 06:23:53 EDT
I am not sure, but we might need additional udev patches according to:

http://thread.gmane.org/gmane.linux.hotplug.devel/15823
Comment 21 Phil Knirsch 2010-06-28 09:29:25 EDT
With the fix in anaconda now (see bug #605262) could you please retest this?

Also, are the symlinks there after the first reboot?

Thanks & regards, Phil
Comment 22 Harald Hoyer 2010-06-29 06:39:45 EDT
udev-147-2.19.el6
Comment 23 Harald Hoyer 2010-06-29 06:50:22 EDT
udev-147-2.20.el6
Comment 24 Alexander Todorov 2010-07-01 04:48:18 EDT
Tested with the 0630.n.0 nightly which has udev-147-2.20.el6 and anaconda-13.21.55-1.el6 with the steps to reproduce from comment #0.

In stage2 in anaconda under /dev/disk/by-path there is an entry for the vda disk: 
virtio-pci-virtio1 -> ../../vda

as well as for the iSCSI disk. 


Installation completed successfully and system was able to boot. Moving to VERIFIED.
Comment 25 Alexander Todorov 2010-07-07 02:33:13 EDT
*** Bug 607661 has been marked as a duplicate of this bug. ***
Comment 27 releng-rhel@redhat.com 2010-11-10 16:50:12 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.