Bug 60127 - rsync-2.4.6-10 errata ignores --address option
rsync-2.4.6-10 errata ignores --address option
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rsync (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 12:55 EST by Greg Bailey
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 12:55:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Bailey 2002-02-20 12:55:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
When upgrading rsync from 2.4.6-2 (RedHat 7.1--RedHat 7.2 has same errata
version) to the latest errata version (2.4.6-10), the --address option stops
working.  As a RedHat mirror maintainer, my rsync scripts no longer work to
RedHat's servers because the connections originate from a different IP address.
 I verified with tcpdump that the origin IP is NOT the one specified with --address.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Upgrade rsync to latest errata version (2.4.6-10 as of writing)
2.  Attempt rsync with "--address" option.
3.  Notice with tcpdump that the source IP address is not the one specified
	

Actual Results:  In the case of mirroring RedHat's FTP site, I got "connection
reset by peer" messages.

Expected Results:  Should have successful rsync execution.

Additional info:

rsync script (excerpt):

rsync --address 199.172.8.160 -av --delete \
  rhm1.redhat.com::redhat/linux/6.2/en/iso/ \
  /var/ftp/pub/redhat/linux/6.2/en/iso/

Output:

read error: Connection reset by peer

tcpdump Output:

10:45:51.419455 eth0 > 199.172.8.152.47736 > 63.240.14.67.rsync: S
1047950309:1047950309(0) win 5840 <mss 1460,sackOK,timestamp 16279085
0,nop,wscale 0> (DF)
10:45:51.545291 eth0 > 199.172.8.152.47736 > 63.240.14.67.rsync: .
1047950310:1047950310(0) ack 1034653958 win 5840 (DF)
10:45:51.545466 eth0 > 199.172.8.152.47736 > 63.240.14.67.rsync: P 0:12(12) ack
1 win 5840 (DF)

The above box has both 199.172.8.152 AND 199.172.8.160 configured.
Comment 1 Bill Nottingham 2002-02-20 16:59:29 EST
Will be fixed in rsync-2.4.6-12.

Note You need to log in before you can comment on or make changes to this bug.