Bug 60133 - crashes when no media in SCSI Jaz Drive
Summary: crashes when no media in SCSI Jaz Drive
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
: 86589 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-20 18:28 UTC by Alan O
Modified: 2013-04-02 04:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 19:34:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan O 2002-02-20 18:28:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
I just installed an old SCSI card and Jaz drive, and when I run hwbrowser
without media in the drive (or when the drive is switched off), the program
exits without displaying the main window.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run hwbrowser with no media in Jaz drive (or Jaz Drive switched off)
2.
3.
	

Actual Results:  hwbrowser dies with the following:
[root@otterpop root]# hwbrowser

Gdk-WARNING **: locale not supported by C library

Gdk-WARNING **: locale not supported by C library

Gdk-WARNING **: locale not supported by C library


Gdk-WARNING **: locale not supported by C library
Gdk-WARNING **: locale not supported by C library
Traceback (innermost last):
  File "/usr/share/hwbrowser/DeviceList.py", line 158, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 151, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 398, in initialize
    disk = parted.PedDevice.get ('/dev/' + device.kudzu_device.device)
parted.error: Error: Error opening /dev/sda: No medium found
[root@otterpop root]# 

Expected Results:  hwbrowser should have run properly

Additional info:

Comment 1 Jonathan Blandford 2002-03-27 19:52:38 UTC
Fixed in CVS.  Should be in the next version.

Comment 2 Brent Fox 2003-03-26 17:25:56 UTC
*** Bug 86589 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.