Bug 601347 - /proc inodes pin task_structs in ram
Summary: /proc inodes pin task_structs in ram
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.8
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jerome Marchand
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
: 591205 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 18:14 UTC by Casey Dahlin
Modified: 2014-06-18 08:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 19:17:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Casey Dahlin 2010-06-07 18:14:27 UTC
If a file or directory in /proc is kept open after a task has exited, its inode retains a reference to the task struct, thus preventing a large chunk of memory from being freed. Under the right workload, staggering amounts of ram can be eaten by dead task structs that are being pinned by /proc inodes.

Version-Release number of selected component (if applicable):
2.6.9-89.0.11

Additional info:

Patch to address this issue is:
99f895518368252ba862cc15ce4eb98ebbe1bec6

With a followup:
13b41b09491e5d75e8027dca1ee78f5e073bc4c0

Comment 1 Casey Dahlin 2010-06-07 18:15:00 UTC
*** Bug 591205 has been marked as a duplicate of this bug. ***

Comment 2 Linda Wang 2010-07-14 19:17:58 UTC

*** This bug has been marked as a duplicate of bug 604777 ***


Note You need to log in before you can comment on or make changes to this bug.