Bug 60145 - Current glibc builds break building KDE
Summary: Current glibc builds break building KDE
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 60038
TreeView+ depends on / blocked
 
Reported: 2002-02-20 21:43 UTC by Bernhard Rosenkraenzer
Modified: 2016-11-24 15:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 17:32:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2002-02-20 21:43:38 UTC
Description of Problem:
As soon as glibc 2.2.90-5 or 2.2.90-6 are installed, all KDE packages fail to
build because am_edit (part of KDE) starts outputting bad makefiles.

Version-Release number of selected component (if applicable):
2.2.90-5, 2.2.90-6

How Reproducible:
100%

Steps to Reproduce:
1. Try building any KDE package

Actual Results:
make just says "docs-am: Nothing to do"

Expected Results:
make builds the whole package

Additional Information:
2.2.90-3 worked, didn't try 2.2.90-4

automake generates proper Makefile.in files, then am_edit is run. Usually, it
just edits the Makefile.in files, with current glibcs, it deletes them and
outputs garbage.

Comment 1 Bernhard Rosenkraenzer 2002-02-20 22:06:04 UTC
Just tried, 2.2.90-4 is broken as well. 2.2.90-3 is the last version that works.

You'll probably want to try it using the arts package, it doesn't require a
whole KDE development environment.

Comment 3 Bernhard Rosenkraenzer 2002-03-04 17:39:44 UTC
package built


Note You need to log in before you can comment on or make changes to this bug.