Bug 60146 - a2ps outputs invalid postscript if LC_NUMERIC is any locale except C, POSIX or en_*
a2ps outputs invalid postscript if LC_NUMERIC is any locale except C, POSIX o...
Status: CLOSED DUPLICATE of bug 40532
Product: Red Hat Linux
Classification: Retired
Component: a2ps (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 17:43 EST by elias
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 17:43:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description elias 2002-02-20 17:43:46 EST
Description of Problem:

a2ps outputs invalid postscript if LC_NUMERIC is any locale except C, POSIX or en_*

This is due to the fact that in most locales except English, American, C and
POSIX, decimal_point is "," and not ".". Postscript, however, always expects


Version-Release number of selected component (if applicable):

a2ps-4.13b-15

How Reproducible:

100%

Steps to Reproduce:
1. export LC_NUMERIC=is_IS
2. echo test|a2ps -o test.ps
3. gs test.ps

Actual Results:

gs test.ps fails. Examination of the postscript code reveals that linux 693
reads thus:

/th 15,000000 def

Expected Results:

line 693 in valid postscript should read like this:

/th 15.000000 def

Additional Information:
Comment 1 Tim Waugh 2002-02-20 18:23:31 EST

*** This bug has been marked as a duplicate of 40532 ***

Note You need to log in before you can comment on or make changes to this bug.