Bug 601461 - auto installation onto NetApp iSCSI storage get hang with Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (bnx2)
auto installation onto NetApp iSCSI storage get hang with Broadcom Corporatio...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ovirt-node (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: Alan Pevec
Virtualization Bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 22:53 EDT by Vivian Bian
Modified: 2016-04-26 11:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On machines with the Broadcom NetXtreme II BCM5708 Gigabit Ethernet controller, an automatic installation of Red Hat Enterprise Virtualization Hypervisor on a NetApp iSCSI storage could stop responding during an attempt to restart the machine. With this update, this error no longer occurs, and the automatic installation no longer fails to reboot the computer.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 13:41:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console log for reproducer with initscript changed with set -x in /etc/rc (542.26 KB, text/plain)
2010-06-09 04:03 EDT, Vivian Bian
no flags Details
serial console log for reproducer with initscript changed with set -x in /etc/init.d/function __umount_loop() function (2.25 KB, text/plain)
2010-06-12 06:04 EDT, Vivian Bian
no flags Details
kernel_panic2.txt (11.04 KB, text/plain)
2010-10-14 02:22 EDT, Ying Cui
no flags Details

  None (edit)
Comment 1 Vivian Bian 2010-06-07 23:00:48 EDT
QE lab bnx2 info
==================

[root@intel-5205-32-1 ~]# lspci |grep Ethernet -i
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
07:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
09:01.0 Ethernet controller: QLogic Corp. ISP4032-based Ethernet IPv6 NIC
[root@intel-5205-32-1 ~]# lspci -n |grep 03:00.0
03:00.0 0200: 14e4:164c (rev 12) 

QE checked 
============
get a hang when umounting filesystems during finish autoinstallation and reboot


devel lab bnx2 info
=====================

 # lspci | grep Ethernet -i
 39:02.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5706
 Gigabit Ethernet (rev 02)


devel checked 
================

pxeboot command line:
management_server=rhevm.virt.bos.redhat.com storage_vol=:::::
hostname=rhev.virt.bos.redhat.com local_boot console=tty1
console=ttyS0,115200n8 rootpw=8QkUVaou1iVw6
storage_init=/dev/mapper/3600c0ff000d7a*
netconsole_server=rhevm.virt.bos.redhat.com 

Did not encounter this hang.



conclusion
==========
this bug need to investigate to narrow where the bug is lying . But please add relnote for this quirk first .
Comment 2 Vivian Bian 2010-06-09 02:11:18 EDT
QE tried to install RHEVH onto Dell Equallogic iSCSI storage with Broadcom NIC . Didn't meet umount filesystem hang .

QE is now trying to install RHEL5.5 onto NetApp iSCSI with Broadcom NIC . Then will decide whether it would be a blocker bug after collecting needed info.
Comment 3 Vivian Bian 2010-06-09 04:03:35 EDT
Created attachment 422467 [details]
serial console log for reproducer with initscript changed with set -x in /etc/rc

This is a comparation file for installation onto NetApp iSCSI storage. In the file , there are three-time installation process. The last one is the reproducer which is the PXE auto installation. The other part is the record for automatic installation from CDROM .
Comment 5 Vivian Bian 2010-06-12 06:04:12 EDT
Created attachment 423473 [details]
serial console log for reproducer with initscript changed with set -x in /etc/init.d/function __umount_loop() function
Comment 9 Ying Cui 2010-10-14 02:22:09 EDT
Created attachment 453380 [details]
kernel_panic2.txt
Comment 12 Ying Cui 2010-10-20 05:38:29 EDT
For comment#9, I have submit a new bug for kernel panic issue.
 https://bugzilla.redhat.com/show_bug.cgi?id=644777
Comment 13 Alan Pevec 2010-11-03 18:26:14 EDT
Original issue looks like a duplicate of bug 583218, next RHEV-H 5.6 build will pick initscript-8.45.33-1.el5
Comment 16 Guohua Ouyang 2010-12-07 02:59:07 EST
I try to reproduce the bug on the same machine intel-5205-32-1 and the same storage (Netapp iSCSI storage), didn't reproduce the hang issue, test matrix:

Build             auto-install-by       times
5.5-2.2.7.3       pxe                   8
5.5-2.2.7.3       usb                   2
5.5-2.2.1         cdrom                 2
5.5-2.2.8.4       pxe                   1
5.5-2.2.8.5       pxe                   2
5.6.4             pxe                   3
5.6-5.1           pxe                   2
5.6-6.1           pxe                   4
5.6-6.1           usb                   1

then, I did not reproduce the issue over 20 times.
Comment 17 Guohua Ouyang 2010-12-13 04:02:51 EST
Tried this bug about 15 times on build 5.6-7, did not reproduce, seems fixed.
Close this bug currently as it's low rate reproduciable bug and will reopen it if encounter future.
Comment 18 Guohua Ouyang 2010-12-13 04:09:25 EST
(In reply to comment #17)
> Tried this bug about 15 times on build 5.6-7, did not reproduce, seems fixed.
> Close this bug currently as it's low rate reproduciable bug and will reopen it
> if encounter future.

Clarify: I reproduced the bug on build 5.5-2.2.8.5 once, not every time.
Status: verified.
Comment 19 Ying Cui 2010-12-13 04:14:05 EST
According to comment 17 and comment 18, change it to 'Verified'
Comment 20 Jaromir Hradilek 2011-01-06 08:52:44 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
On machines with the Broadcom NetXtreme II BCM5708 Gigabit Ethernet controller, an automatic installation of Red Hat Enterprise Virtualization Hypervisor on a NetApp iSCSI storage could stop responding during an attempt to restart the machine. With this update, this error no longer occurs, and the automatic installation no longer fails to reboot the computer.
Comment 22 errata-xmlrpc 2011-01-13 13:41:05 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0148.html

Note You need to log in before you can comment on or make changes to this bug.