Bug 601551 - libvirt-qpid can't correctly get number of domain
libvirt-qpid can't correctly get number of domain
Status: CLOSED DUPLICATE of bug 596682
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt-qpid (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ian Main
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 03:51 EDT by Alex Jia
Modified: 2010-07-19 13:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 13:20:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2010-06-08 03:51:58 EDT
Description of problem:
There are three domains in current system and they are shutoff status.
but it's number only display one using qpid-tool.


Version-Release number of selected component (if applicable):
[root@dhcp-66-70-62 bug]# cat /etc/redhat-release
Red Hat Enterprise Linux release 6.0 Beta (Santiago)

[root@dhcp-66-70-62 bug]# uname -a
Linux dhcp-66-70-62.nay.redhat.com 2.6.32-25.el6.x86_64 #1 SMP Mon May 10 17:30:22 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

[root@dhcp-66-70-62 bug]# rpm -qa libvirt
libvirt-0.8.1-7.el6.x86_64

[root@dhcp-66-70-62 bug]# rpm -qa|grep qpid
libvirt-qpid-0.2.20-2.el6.x86_64
qpid-cpp-server-xml-0.7.946106-2.el6.x86_64
qpid-cpp-client-0.7.946106-2.el6.x86_64
python-qpid-0.7.946106-1.el6.noarch
libvirt-qpid-debuginfo-0.2.20-2.el6.x86_64
qpid-tools-0.7.946106-3.el6.noarch
qpid-cpp-server-0.7.946106-2.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1.service qpidd start
2.service libvirt-qpid start
3.qpid-tool
  
Actual results:
[root@dhcp-66-70-62 libvirt-test-API]# virsh list --all
 Id Name                 State
----------------------------------
  - rhel5u4-qcow2        shut off
  - rhel5u4-raw          shut off
  - rhel5u5              shut off
[root@dhcp-66-70-62 libvirt-test-API]# qpid-tool
Management Tool for QPID
qpid: list
Summary of Objects by Type:
    Package                 Class         Active  Deleted
    =======================================================
    com.redhat.libvirt      domain        1       0
    org.apache.qpid.broker  queue         5       0
    org.apache.qpid.broker  binding       17      0
    com.redhat.libvirt      pool          1       0
    org.apache.qpid.broker  subscription  4       0
    org.apache.qpid.broker  vhost         1       0
    org.apache.qpid.broker  connection    2       0
    com.redhat.libvirt      node          1       0
    org.apache.qpid.broker  exchange      9       0
    org.apache.qpid.broker  session       2       0
    org.apache.qpid.broker  broker        1       0
    org.apache.qpid.broker  system        1       0
    com.redhat.libvirt      volume        1       0
qpid: list domain
Object Summary:
    ID   Created   Destroyed  Index
    ==============================================================================
    143  00:00:00  -          com.redhat.libvirt:domain:com.redhat.libvirt:node:
qpid: show 143
Object of type: com.redhat.libvirt:domain(b84f5eed-5ed5-3b70-077b-127b3f3e5fa5)
    Attribute      143
    ===================================================================================================
    uuid           'daab6033-e29f-53a4-99e8-45c1a4df8881'
    name           'rhel5u4-qcow2'
    id             -1
    node           0-1-1-vendor:product:dd8811a9-6240-41f0-b684-c2325cd90024-com.redhat.libvirt:node:
    state          'shutoff'
    numVcpus       1
    active         'false'
    maximumMemory  1048576
    memory         1048576
    cpuTime        0

Expected results:
correctly display current domain information

Additional info:
Note that, the same error occurs pool and volume.
Comment 2 RHEL Product and Program Management 2010-06-08 04:13:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-07-15 10:48:15 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Ian Main 2010-07-19 13:20:08 EDT
Is this not a duplicate of:

https://bugzilla.redhat.com/show_bug.cgi?id=596682

*** This bug has been marked as a duplicate of bug 596682 ***

Note You need to log in before you can comment on or make changes to this bug.