Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601561 - Network connection lost with Intel 82574L gigabit network card
Network connection lost with Intel 82574L gigabit network card
Status: CLOSED DUPLICATE of bug 601556
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 04:05 EDT by ahoff_10
Modified: 2010-06-14 17:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 17:08:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "dmesg" (43.94 KB, text/plain)
2010-06-08 04:05 EDT, ahoff_10
no flags Details

  None (edit)
Description ahoff_10 2010-06-08 04:05:35 EDT
Created attachment 422090 [details]
Output of "dmesg"

Description of problem:
After the transfer of some kilobytes the network connection is interrupted and subsequently no longer available.

Version-Release number of selected component (if applicable):
Fedora 12, Fixlevel at least 2010-05-20 and before

How reproducible:
Install Fedora 12 und it's latest fixes or start the system from a Fedora live cd. Set up the network and try to transfer a file over the network i. e. by using ssh. After the transfer of some kilobytes (always below 3 MB) the network connection is interrupted and the system can't be reached via network anymore.

After a restart of the system a login via ssh is possible, but the connection will be lost again after transfering some kilobytes.

The system uses a "Supermicro X8SIL" mainboard with onboard network interfaces (Intel Corporation 82574L Gigabit Network Connection). The problem doesn't occur when using Debian 5.0 or the latest CentOS version (live cd) on the same system.

Steps to Reproduce:
1. Install Fedora 12 or start the system from a Fedora live cd
2. Setup network
3. Try to transfer a file of at least 3 MB via network i. e. SCP
  
Actual results:
Network connection will be lost during the transfer. If the data transfer is monitored with tcpdump, the system sends arp requests to it's gateway when loosing the network connection.

Expected results:
The file is transferred correctly and completely. 

Additional info:

Output of "lspci"
------------------
00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
00:05.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 3 (rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation 3400 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 5 Series/3400 Series Chipset 2 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 5 Series/3400 Series Chipset 2 port SATA IDE Controller (rev 05)
04:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
05:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
06:03.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200eW WPCM450 (rev 0a)

Output of "lsmod":
-------------------
fbcon                  39270  71 
tileblit                2487  1 fbcon
font                    8053  1 fbcon
bitblit                 5811  1 fbcon
softcursor              1565  1 bitblit
vga16fb                12757  1 
vgastate                9857  1 vga16fb
lp                      9336  0 
parport                37160  1 lp
usb_storage            49801  0 
e1000e                136205  0
Comment 1 Chuck Ebbert 2010-06-14 17:08:22 EDT

*** This bug has been marked as a duplicate of bug 601556 ***

Note You need to log in before you can comment on or make changes to this bug.