This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 601573 - Consider to package clang seperately
Consider to package clang seperately
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 04:39 EDT by Chen Lei
Modified: 2010-06-10 12:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 12:19:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chen Lei 2010-06-08 04:39:54 EDT
Description of problem:
According to fedora package guideline, different project should be packaged seperately.

See http://fedoraproject.org/wiki/PackagingGuidelines#Bundling_of_multiple_projects


It'll be better to package clang seperately, thank you!
Comment 1 Michel Alexandre Salim 2010-06-08 06:42:09 EDT
Clang is designed to be built as part of the LLVM project:

http://clang.llvm.org/get_started.html

so I don't think it actually counts as a different project here. They are released simultaneously too.

Let me know if you think this explanation suffices, in which case I can close the bug, otherwise, it might be nice to get a clarification from the Packaging Committee.
Comment 2 Chen Lei 2010-06-08 09:01:14 EDT
(In reply to comment #1)
> Clang is designed to be built as part of the LLVM project:
> http://clang.llvm.org/get_started.html
> so I don't think it actually counts as a different project here. They are
> released simultaneously too.
> Let me know if you think this explanation suffices, in which case I can close
> the bug, otherwise, it might be nice to get a clarification from the Packaging
> Committee.    

I think it'll be much better to package it seperately, other distributions such as debian, gentoo package llvm and clang seperatley.

In fedora, at least font guideline don't permit bundling several tarball in one srpm. 

http://fedoraproject.org/wiki/Packaging:FontsPolicy

Take xulrunner for a example, several months ago fedora package them in one srpm along with xulrunner-python. Now, we package them seperately because upstream release them in two seperate tarballs. qt/qt-qt-assistant-adp and libktorrent/ktorrent is the same case.
Comment 3 Michel Alexandre Salim 2010-06-10 12:19:05 EDT
I appreciate the comparison to other cases, but again, in this case these are two tightly coupled projects where it would not, as yet, make much sense to package them separately.

Looking at the Gentoo example:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-devel/clang/clang-2.7.ebuild?revision=1.1&view=markup

They actually downloaded an entire copy of LLVM, build it, and clang, but then only package the clang bits.

There's this upstream bug report, that's oddly marked as CLOSED despite clang not really being easily buildable out-of-tree,

http://llvm.org/bugs/show_bug.cgi?id=4840

Once clang has clear instructions for building out-of-tree then I'll certainly create a separate package for it, and make whatever (reasonable) modifications to our LLVM package needed to get it to compile. However, at the moment it does not seem like the most productive use of time.

PS A lot of non-font packages do come with multiple tarballs. See for example pidgin.

Note You need to log in before you can comment on or make changes to this bug.