Bug 60163 - "bad load average returned" when using ruptime or rup
"bad load average returned" when using ruptime or rup
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brian Brock
:
: 60165 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 19:50 EST by Johnray Fuller
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 18:13:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Johnray Fuller 2002-02-20 19:50:20 EST
Description of Problem:

When users configure piranha to use rup or ruptime for load balanciing, they get
the following message every X seconds:

"bad load average returned: ha1           up      6:10,     1 user,   load 0.00,
0.02, 0.00 localhost     up      6:12,     3 users,  load 0.00, 0."

If bad load average means the machine is overloaded, it is wrong. If it means it
can't read the values returned, it is worse than wrong, it's dumb.

Version-Release number of selected component (if applicable):

piranha-0.6.0-15

How Reproducible:

Every time...

Steps to Reproduce:
1. start rwhod on *both* the lvs routers and the real servers. 
2. tail -f var/log/messages, select ruptime in the virtual server tab, and     
   restart pulse
3. what the mystical messages scroll across your screen.

Actual Results:

/var/log/messages returns this:

"bad load average returned: ha1           up      6:10,     1 user,   load 0.00,
0.02, 0.00 localhost     up      6:12,     3 users,  load 0.00, 0."


Expected Results:

It should be returning the stats or something instead of indicating a problem.

Additional Information:
	
I have yet to test "uptime" You probably should though since these seem to be
broken.
Comment 1 Johnray Fuller 2002-05-01 18:13:38 EDT
Is this fixed ???

Please close if it is...

J
Comment 2 Phil Copeland 2002-05-02 02:25:05 EDT
Sorry, missed that one.
Tim/Jay won't do a respin to pull it in so it'll have to be an errata item (done
as errata already)

Phil
=--=
Comment 3 Phil Copeland 2002-05-02 02:27:08 EDT
*** Bug 60165 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.