Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601644 - anaconda should install tools to boot the system
anaconda should install tools to boot the system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
: Reopened
Depends On:
Blocks: 582286 598509
  Show dependency treegraph
 
Reported: 2010-06-08 07:51 EDT by Harald Hoyer
Modified: 2010-11-10 14:47 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-13.21.51-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 598509
Environment:
Last Closed: 2010-11-10 14:47:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Harald Hoyer 2010-06-08 07:53:58 EDT
if dracut would not pull in:

- cryptsetup-luks  
- device-mapper  
- dhclient  
- dmraid  
- lvm2
- mdadm  
- plymouth

they might be missing, if required. So either anaconda should pull them in, if required to setup any disk device or the component should be in the core group and installed every time.
Comment 2 Hans de Goede 2010-06-08 08:01:58 EDT
I don't see either dhclient (should be required by dracut-network) or plymouth (no idea) as anaconda's problem, the rest I've a patch for.
Comment 3 Alexander Todorov 2010-06-08 09:05:36 EDT
Harald,
the 0531.1 build is old. Latest one is 0603.1. The bug you describe is 598509 - I've used the same tree and same steps to reproduce as you when originally filed. lvm package was in the optional repository for WebServer and not pulled in during installation that's why boot failed.

All the dependencies are now required by dracut-004-20.1.el6, see:
https://bugzilla.redhat.com/show_bug.cgi?id=598509#c12

With the latest build (0603.1) WebServer minimal installation in KVM works as expected.

*** This bug has been marked as a duplicate of bug 598509 ***
Comment 4 Harald Hoyer 2010-06-08 09:36:21 EDT
(In reply to comment #3)

> All the dependencies are now required by dracut-004-20.1.el6, see:
> https://bugzilla.redhat.com/show_bug.cgi?id=598509#c12
> 

This is why I filed the bug! The requirements in dracut should not be needed.

You cannot deinstall dracut. So, all the requirements of dracut cannot be removed from the system. 

There is no need to install lvm, dmraid, mdadm, dhclient, etc. on every system!!!
Comment 6 Bill Nottingham 2010-06-08 13:27:11 EDT
dracut should be pulling in plymouth; it's an initramfs component common to every initramfs.
Comment 7 Harald Hoyer 2010-06-09 04:28:28 EDT
(In reply to comment #6)
> dracut should be pulling in plymouth; it's an initramfs component common to
> every initramfs.    

right, it will, although initscripts might also require plymouth to work properly.
Comment 8 Harald Hoyer 2010-06-11 09:12:11 EDT
So, these are left to be pulled in by anaconda on demand
- cryptsetup-luks  
- device-mapper  
- dmraid  
- lvm2
- mdadm
Comment 9 Hans de Goede 2010-06-12 09:02:13 EDT
This is fixed in anaconda-13.21.51-1, moving to modified.
Comment 11 Pavel Holica 2010-07-07 05:32:32 EDT
Verified on RHEL6.0-20100701.3 WebServer and ComputeNode x86_64
Comment 12 releng-rhel@redhat.com 2010-11-10 14:47:10 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.