Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601646 - =~ no longer working
=~ no longer working
Status: CLOSED DUPLICATE of bug 558537
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bash (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Roman Rakus
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 07:53 EDT by Levente Farkas
Modified: 2014-01-12 19:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 08:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2010-06-08 07:53:17 EDT
=~ no longer working in bash-4.1.2-2.el6. just try this little line:
if [[ "abc" =~ "abc.*" ]]; then echo inside; else echo outside; fi
this give "inside" on rhel-5, and up to fedora-12.
imho it's a serious error since all shell script are fail when use =~ :-(
Comment 2 RHEL Product and Program Management 2010-06-08 08:13:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Roman Rakus 2010-06-08 08:51:44 EDT
Yep, and it is documented.
see https://bugzilla.redhat.com/show_bug.cgi?id=558537
Comment 4 Roman Rakus 2010-06-08 09:01:40 EDT

*** This bug has been marked as a duplicate of bug 558537 ***
Comment 5 Ferry Huberts 2010-08-13 05:43:31 EDT
I'm getting hit with this bug while porting my applications.

Also: "You are not authorized to access bug #558537."

Not funny. I'd like to read this documentation!

Note You need to log in before you can comment on or make changes to this bug.