Bug 601754 - koji list-buildroot constrains buildroot ID to decimal number
Summary: koji list-buildroot constrains buildroot ID to decimal number
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-08 15:00 UTC by Petr Pisar
Modified: 2013-01-10 06:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 21:33:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Pisar 2010-06-08 15:00:56 UTC
$ koji list-targets --name dist-f14-perltest
Name                           Buildroot                      Destination                   
---------------------------------------------------------------------------------------------
dist-f14-perltest              dist-f14-perltest              dist-f14-perltest

$ koji list-buildroot dist-f14-perltest
ValueError: invalid literal for int() with base 10: 'dist-f14-perltest'

koji does not expect number in place of buildroot obviously. This is insufficient as dedicated targets have its own special buildroot ID.

Using "14" for "dist-f14-build" works:

$ koji list-buildroot 14 |head
MAKEDEV-3.23-1.2.i386
SysVinit-2.86-14.i386
audit-libs-1.2.8-1.fc6.i386
basesystem-8.0-5.1.1.noarch
bash-3.1-16.1.i386
beecrypt-4.1.2-10.1.1.i386
binutils-2.17.50.0.3-6.i386
buildsys-macros-6-1.fc6.noarch
bzip2-1.0.3-3.i386
bzip2-libs-1.0.3-3.i386

Comment 1 Mike McLean 2010-06-08 21:33:38 UTC
Unfortunately koji deals with a number of overloaded terms. We try to be internally consistent, but can cannot control how others chose to talk about koji or build tools in general.

In Koji, a buildroot is the chroot environment on a build host that is used to perform various tasks (mainly builds). Since Koji generates fresh buildroots for each build there are a *lot* of buildroots.

Buildroots do not have any sort of name. They only have a numeric id. You seem to want to refer to a build root by a tag name, but a tag can correspond to many, many buildroots (or none at all).

While the list-buildroot command could certainly use a few improvements, the one you're asking for is nonsensical.


Note You need to log in before you can comment on or make changes to this bug.