Bug 601878 - clvmd -R segfaults when clvmd is not running
Summary: clvmd -R segfaults when clvmd is not running
Status: CLOSED DUPLICATE of bug 574595
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-08 19:47 UTC by Nate Straz
Modified: 2010-06-09 04:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 04:09:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nate Straz 2010-06-08 19:47:50 UTC
Description of problem:
[root@morph-01 ~]# ps -C clvmd
  PID TTY          TIME CMD
[root@morph-01 ~]# clvmd -R
connect() failed on local socket: Connection refused
Segmentation fault (core dumped)
[root@morph-01 ~]# gdb /usr/sbin/clvmd core
Core was generated by `clvmd -R'.
Program terminated with signal 11, Segmentation fault.
#0  0x00183c65 in __libc_free (mem=0x1d16ab) at malloc.c:3724
3724      ar_ptr = arena_for_chunk(p);
(gdb) bt
#0  0x00183c65 in __libc_free (mem=0x1d16ab) at malloc.c:3724
#1  0x08059aaa in _cluster_free_request (response=0x1d16ab, num=0)
    at refresh_clvmd.c:287
#2  0x0805a5fd in refresh_clvmd (all_nodes=1) at refresh_clvmd.c:322
#3  0x0805675c in main (argc=2, argv=0xbfe52f94) at clvmd.c:319
(gdb)


Version-Release number of selected component (if applicable):
lvm2-cluster-2.02.66-2.el6.i686

How reproducible:
Easily

Steps to Reproduce:
1. service clvmd stop
2. clvmd -R
3.
  
Actual results:
core dump

Expected results:
Print error about clvmd not running and return non-zero.

Additional info:

Comment 2 RHEL Product and Program Management 2010-06-08 20:13:19 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Milan Broz 2010-06-09 04:09:36 UTC

*** This bug has been marked as a duplicate of bug 574595 ***


Note You need to log in before you can comment on or make changes to this bug.