Bug 60195 - Python crashes and up2date dies
Summary: Python crashes and up2date dies
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-21 19:44 UTC by Toni Willberg
Modified: 2015-01-07 23:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 17:27:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of crashed python (13.47 KB, text/plain)
2002-02-21 19:46 UTC, Toni Willberg
no flags Details
backtrace for up2date crash by tomg@io.com (5.64 KB, text/plain)
2002-03-29 14:19 UTC, tom georgoulias
no flags Details

Description Toni Willberg 2002-02-21 19:44:13 UTC
Description of problem:

 Up2date dies always in one of my computers, using GUI or not. There is
something wrong with python or some python script that up2date is using.


Version-Release number of selected component (if applicable):

 up2date-2.7.2-7.x.6
 rpm-4.0.3-1.03


How reproducible:
 Always

Steps to Reproduce:
 1. su -l
 2. up2date
 3. click next untill it crashes
	

Actual Results:  see attachment for backtrace

Comment 1 Toni Willberg 2002-02-21 19:46:29 UTC
Created attachment 46280 [details]
backtrace of crashed python

Comment 2 Adrian Likins 2002-02-22 18:17:37 UTC
Looks like it's dying deep down in rpm land. It's possible this
might be caused by corrupt headers.

try:
    rm -rf /var/spool/up2date/*

And running up2date again.

Comment 3 tom georgoulias 2002-03-29 14:18:10 UTC
THis happens to me as well, even after deleting everything from /var/spool/up2date/



Comment 4 tom georgoulias 2002-03-29 14:19:40 UTC
Created attachment 51384 [details]
backtrace for up2date crash by tomg@io.com

Comment 5 Adrian Likins 2002-04-01 17:27:07 UTC
looks to be something down in librpm, I'll alert the rpm maintainer
and try to track down whats causing that.

Comment 6 Beth Uptagrafft 2002-04-03 22:01:22 UTC
fixed in next release


Note You need to log in before you can comment on or make changes to this bug.