Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 602048 - please change the requires from /usr/lib/gcj/itext/itext-2.1.7.jar.so to itext%{?_isa}
please change the requires from /usr/lib/gcj/itext/itext-2.1.7.jar.so to itex...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pdftk (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 23:46 EDT by seth vidal
Modified: 2013-07-28 21:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 14:18:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description seth vidal 2010-06-08 23:46:41 EDT
if the requires is not a file-requires then we save our users from having to download the filelist metadata when installing this pkg.
Comment 1 Orcan Ogetbil 2010-06-09 09:18:34 EDT
This is a duplicate of bug 533944, which appears to be fixed in rawhide. Why is there a regression?
Comment 2 seth vidal 2010-06-09 09:24:26 EDT
Then the pkg was never built.
repoquery --repoid=rawhide -q -R pdftk
/usr/lib/gcj/itext/itext-2.1.7.jar.so
itext(x86-32) >= 2.1.7-1
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libgcc_s.so.1
libgcc_s.so.1(GCC_3.0)
libgcj.so.10
libm.so.6
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.11)
libstdc++.so.6(GLIBCXX_3.4.9)

so it looks like the isa requires was added but the file-requires was never removed
Comment 3 Orcan Ogetbil 2010-06-09 22:00:32 EDT
I see that the %__find_requires bug is not fixed and is still generating the weird dependency /usr/lib64/gcj/itext/itext-x.y.z.jar.so()(64bit)

So, since Requires: itext%{?_isa} is already in the specfile, we just need to get rid of the weird dependency altogether by modifying our %__find_requires hack.

This can be done by changing the line
     | sed 's@\(itext-[0-9.]*\.jar\.so\)\(()(64bit)\)\?@\1@'
to
     | sed '\@itext-[0-9.]*\.jar\.so@d'

Jochen, any objections?
Comment 4 Jochen Schmitt 2010-06-17 14:18:11 EDT
Should be fixed with pdftk-1.41-24.
Comment 5 Jochen Schmitt 2010-06-17 15:11:40 EDT
sorry, caused by an error of me, it should be pdftk-1.41-26.

Note You need to log in before you can comment on or make changes to this bug.