Bug 602080 - X server causes unnecessary fb resize on startup
Summary: X server causes unnecessary fb resize on startup
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ben Skeggs
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: Patch, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-09 05:35 UTC by Ben Skeggs
Modified: 2010-11-15 14:52 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-server-1.7.7-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 14:52:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch correcting the issue (1.43 KB, patch)
2010-06-09 05:35 UTC, Ben Skeggs
no flags Details | Diff

Description Ben Skeggs 2010-06-09 05:35:44 UTC
Created attachment 422441 [details]
patch correcting the issue

In multiple display configurations, due to a typo in the X server, the initial framebuffer will be sized to only fit a single display, resulting in a resize at a later point during init.

This unnecessary resize causes memory fragmentation, which can be a big problem on cards with a limited amount of video memory.

Comment 1 RHEL Product and Program Management 2010-06-09 05:54:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Ben Skeggs 2010-06-09 23:42:40 UTC
MODIFIED xorg-x11-server-1.7.7-6.el6 is in brew.

Comment 5 Vladimir Benes 2010-11-12 13:40:26 UTC
randr-initial patch looks sana is present in newest package and is applied in spec file 
-> SanityOnly

Comment 6 releng-rhel@redhat.com 2010-11-15 14:52:23 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.