Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602095 - [abrt] crash in virt-manager-0.8.2-3.fc12: __init__.py:52:_init:RuntimeError: could not open display
[abrt] crash in virt-manager-0.8.2-3.fc12: __init__.py:52:_init:RuntimeError:...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
abrt_hash:4f66cc03
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 02:30 EDT by Maxim Kuznetsov
Modified: 2010-06-09 12:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 12:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.15 KB, text/plain)
2010-06-09 02:30 EDT, Maxim Kuznetsov
no flags Details

  None (edit)
Description Maxim Kuznetsov 2010-06-09 02:30:23 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: python /usr/share/virt-manager/virt-manager.py
comment: I think, admin was restarting router, so the internet was not enable.
component: virt-manager
executable: /usr/share/virt-manager/virt-manager.py
kernel: 2.6.32.12-115.fc12.x86_64
package: virt-manager-0.8.2-3.fc12
reason: __init__.py:52:_init:RuntimeError: could not open display
release: Fedora release 12 (Constantine)

backtrace
-----
__init__.py:52:_init:RuntimeError: could not open display

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager.py", line 411, in <module>
    _show_startup_error(str(run_e), "".join(traceback.format_exc()))
  File "/usr/share/virt-manager/virt-manager.py", line 54, in _show_startup_error
    import gtk
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
    _init()
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
    _gtk.init_check()
RuntimeError: could not open display

Local variables in innermost frame:
sys: <module 'sys' (built-in)>
sys_path: ['/usr/lib/virt-manager', '/usr/share/virt-manager', '/usr/share/virt-manager', '/usr/lib64/python26.zip', '/usr/lib64/python2.6', '/usr/lib64/python2.6/plat-linux2', '/usr/lib64/python2.6/lib-tk', '/usr/lib64/python2.6/lib-old', '/usr/lib64/python2.6/lib-dynload', '/usr/lib64/python2.6/site-packages', '/usr/lib64/python2.6/site-packages/PIL', '/usr/lib64/python2.6/site-packages/gst-0.10', '/usr/lib64/python2.6/site-packages/gtk-2.0', '/usr/lib64/python2.6/site-packages/webkit-1.0', '/usr/lib/python2.6/site-packages']
Comment 1 Maxim Kuznetsov 2010-06-09 02:30:25 EDT
Created attachment 422450 [details]
File: backtrace
Comment 2 Cole Robinson 2010-06-09 12:31:19 EDT
This means GTK couldn't access the graphical display. Usually this is because the app was run over SSH without -X/-Y, or you used su (NOT su -) and the new user can't access the original users display. Closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.