Bug 602125 - SELinux is preventing /usr/sbin/abrtd "read" access on /var/lib/samba/gencache.tdb.
SELinux is preventing /usr/sbin/abrtd "read" access on /var/lib/samba/ge...
Status: CLOSED DUPLICATE of bug 602118
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:4f401540c46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 04:10 EDT by Harald Jensås
Modified: 2010-06-09 08:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 08:24:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Jensås 2010-06-09 04:10:44 EDT
Summary:

SELinux is preventing /usr/sbin/abrtd "read" access on
/var/lib/samba/gencache.tdb.

Detailed Description:

[abrtd has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:samba_var_t:s0
Target Objects                /var/lib/samba/gencache.tdb [ file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-1.1.1-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-21.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-112.fc13.x86_64 #1 SMP
                              Thu May 27 02:28:31 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Mon 07 Jun 2010 05:43:53 PM CEST
Last Seen                     Mon 07 Jun 2010 05:43:53 PM CEST
Local ID                      56253323-6191-4fcb-ad05-364aff0e1f44
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1275925433.920:284): avc:  denied  { read } for  pid=13558 comm="abrtd" name="gencache.tdb" dev=sda2 ino=393444 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_var_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1275925433.920:284): arch=c000003e syscall=2 success=yes exit=4294967424 a0=7f301800f0e0 a1=0 a2=1a4 a3=0 items=0 ppid=1 pid=13558 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,abrtd,abrt_t,samba_var_t,file,read
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t samba_var_t:file read;
Comment 1 Miroslav Grepl 2010-06-09 08:24:36 EDT

*** This bug has been marked as a duplicate of bug 602118 ***

Note You need to log in before you can comment on or make changes to this bug.